1050 String Subtraction (20分)

 

1050 String Subtraction (20分)

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.
#include <iostream>
#include <algorithm>
#include<vector>
#include<map>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<set>
#include<queue>
#include<climits>
using namespace std;
const int maxn= 1000+5;
	string s1,s2;
bool check(char a){
	for(auto j:s2){
		
		if(j==a) return true; 
	}
	
	return false;	
}


int main(){

	getline(cin,s1);
	getline(cin,s2);
	string res;
	for(auto i:s1){
		if(!check(i)){
			
			res+=i;	
		}
	}
	
	
	cout<<res<<endl;
	return 0;	
}
#include <iostream>
#include <algorithm>
#include<vector>
#include<map>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<unordered_set>
#include<queue>
#include<climits>
using namespace std;
const int maxn= 1000+5;
	string s1,s2;



int main(){

	getline(cin,s1);
	getline(cin,s2);
	unordered_set<char>hash;
	for(auto i:s2) hash.insert(i);
	
	string res;
	for(auto i:s1){
		if(!hash.count(i)){
			
			res+=i;	
		}
	}
	
	
	cout<<res<<endl;
	return 0;	
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值