1021. Deepest Root (25) [图的遍历,DFS,计算连通分量量的个数]

92 篇文章 0 订阅

A graph which is connected and acyclic can be considered a tree. The hight of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10

4

) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5

1 2

1 3

1 4

2 5

Sample Output 1:

3

4

5

Sample Input 2:

5

1 3

1 4

2 5

3 4

Sample Output 2:

Error: 2 components

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
using namespace std;
int n,maxheight=0;
vector<vector<int>> v;
bool visit[10010];
set<int> s;
vector<int> temp;
void dfs(int node,int height){
    if(height>maxheight){
        temp.clear();
        temp.push_back(node);
        maxheight=height;
    }else if(height==maxheight){
        temp.push_back(node);
    }
    visit[node]=true;
    for(int i=0;i<v[node].size();i++){
        if(visit[v[node][i]]==false)
            dfs(v[node][i],height+1);
    }
}
int main(){
    cin>>n;
    v.resize(n+1);
    int a,b,cnt=0,s1=0;
    for(int i=0;i<n-1;i++){
        cin>>a>>b;
        v[a].push_back(b);
        v[b].push_back(a);
    }
    for(int i=1;i<=n;i++){
        if(visit[i]==false){
            dfs(i,0);
            if(i==1){
                if(temp.size()) s1=temp[0];
                for(int j=0;j<temp.size();j++)
                    s.insert(temp[j]);
            }
            cnt++;
        }
    }
    if(cnt>=2) printf("Error: %d components", cnt);
    else {
        temp.clear();
        maxheight=0;
        fill(visit,visit+10010,false);
        dfs(s1,1);
        for(int i=0;i<temp.size();i++)
            s.insert(temp[i]);
        for(auto it=s.begin();it!=s.end();it++)
            cout<<*it<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小火汁猛猛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值