PAT 甲级 1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

代码: 

#include<stdio.h>
#include<string>
#include<queue>
using namespace std;
struct node{
	double coef;//系数
	int exp;//指数
};


int main(){
	int num;
	queue<node> p1,p2,sum;
	if (scanf("%d", &num) != -1){
		for (int i = 0; i < num; i++){
			node temp;
			if ((scanf("%d", &temp.exp) != -1)){
				if (scanf("%lf", &temp.coef) != -1){
					p1.push(temp);
					//printf("aasa%d,,%d,,,,", temp.exp, temp.coef);
				}
			}
		}
		//printf("asadas\n");
	}
	if (scanf("%d", &num) != -1){
		//node p1[num];
		for (int i = 0; i < num; i++){
			node temp;
			if (scanf("%d", &temp.exp) != -1){
				if (scanf("%lf", &temp.coef) != -1){
					p2.push(temp);
					//printf("aasa%d,,%d,,,,", temp.exp, temp.coef);
				}
			}
		}
	}
	while (p1.empty() == false && p2.empty()==false){
		node temp1 = p1.front();
		node temp2 = p2.front();
		if (temp1.exp > temp2.exp){
			p1.pop();
			sum.push(temp1);
		}
		else if (temp1.exp < temp2.exp){
			p2.pop();
			sum.push(temp2);
		}
		else{
			p1.pop();
			p2.pop();
			node temp;
			temp.exp = temp1.exp;
			temp.coef = temp1.coef + temp2.coef;
			if (temp.coef != 0){
				sum.push(temp);
			}
		}
	}
	//printf("111");
	while (p1.empty() == false){
		node temp = p1.front();
		p1.pop();
		sum.push(temp);
	}
	//printf("222");
	while (p2.empty() == false){
		node temp = p2.front();
		p2.pop();
		sum.push(temp);
	}
	printf("%d", (int)sum.size());
	while (sum.empty() == false){
		node temp = sum.front();
		sum.pop();
		printf(" %d %.1f", temp.exp, temp.coef);
	}
	


	return 0;
}

思路:

输入的多项式是按照指数大小兄大到小输入的,是有序的,因此可以参考归并排序合并两个有序数组的思路将对多项式求和。

同样,若输入的多项式无序,可以先排序后按同样的方法处理。

易错点:

两个多项式求和后的结果若为0,不要将其加入结果多项式中。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
牙科就诊管理系统利用当下成熟完善的SSM框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的Mysql数据库进行程序开发。实现了用户在线查看数据。管理员管理病例管理、字典管理、公告管理、药单管理、药品管理、药品收藏管理、药品评价管理、药品订单管理、牙医管理、牙医收藏管理、牙医评价管理、牙医挂号管理、用户管理、管理员管理等功能。牙科就诊管理系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。 管理员在后台主要管理病例管理、字典管理、公告管理、药单管理、药品管理、药品收藏管理、药品评价管理、药品订单管理、牙医管理、牙医收藏管理、牙医评价管理、牙医挂号管理、用户管理、管理员管理等。 牙医列表页面,此页面提供给管理员的功能有:查看牙医、新增牙医、修改牙医、删除牙医等。公告信息管理页面提供的功能操作有:新增公告,修改公告,删除公告操作。公告类型管理页面显示所有公告类型,在此页面既可以让管理员添加新的公告信息类型,也能对已有的公告类型信息执行编辑更新,失效的公告类型信息也能让管理员快速删除。药品管理页面,此页面提供给管理员的功能有:新增药品,修改药品,删除药品。药品类型管理页面,此页面提供给管理员的功能有:新增药品类型,修改药品类型,删除药品类型。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值