HDU 1075 What Are You Talking About【map的应用】

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 26664    Accepted Submission(s): 9129


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
 
 
STARTfrom fiwohello difhmars riwosfearth fnnvklike fiiwjENDSTARTdifh, i'm fiwo riwosf.i fiiwj fnnvk!END
 
Sample Output
 
 
hello, i'm from mars.i like earth!
Hint
Huge input, scanf is recommended.
 

Author
Ignatius.L
 
题意:给你一个火星文字典,再给你一句火星文,让你把火星文翻译出来。如果出现字典里不存在的火星文,则复制下来,标点和格式也一并复制下来。
思路:由每一个翻译都有一个火星文与它对应,因此这里我们要用到STL容器 map。又由火星文和它的翻译的对应关系,即map[火星文]=翻译;当输入一句火星文,提取出它的每个火星文,若存在它的翻译则输出它的翻译,若不存在,则复制这个火星文。若为标点符号,则输出。
注意:string 定义的字符串是不能带空格的

#include<bits/stdc++.h>
using namespace std;
const int Max=3005;
map<string,string>m;
int main()
{
    string s1,s2;
    string b;
    char s3[3005];
    cin>>s1;
    while( cin>>s1)///建立火星文和翻译的对应关系
    {
        if(s1=="END")
            break;
        else
        {
            cin>>s2;
            m[s2]=s1;
        }
    }

    cin>>s3;
    getchar();
    while(1)
    {
        gets(s3);
        if(strcmp(s3,"END")==0)///这里不能用s3=="END"进行比较
            break;
            if(strcmp(s3,"START")==0)
                 continue;
            b="";                  ///初始化'b'
            int len=strlen(s3);
            for(int i=0;i<len;i++)
            {
                if(i==len-1&&(s3[i]>='a'&&s3[i]<='z'))//若i为最后一个字符且为字母时就连接到‘b’后
                {
                    b+=s3[i];
                    if(m[b]!="") //’b‘对应的翻译存在 则输出'b'对应的单词
                        cout<<m[b];
                    else
                        cout<<b;//’b‘对应的翻译不存在 则输出'b'

                }
                if(s3[i]<'a'||s3[i]>'z')
                {
                    if(m[b]!="")
                        cout<<m[b];
                    else
                        cout<<b;
                    b="";
                    cout<<s3[i];//输出标点字符

                }
                else
                    b+=s3[i];
            }
            cout<<endl;
    }
    return 0;
}









 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值