POJ - 1426 Find The Multiple 【深搜】

E - Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题意:求n的任意一个倍数m,即m%n=0, m要满足m的每一位要么是1要么0.

思路:这道题可以用深度优先搜索来做,我们以a=1为顶点开始搜索。

把a的值更新为a=a*10 ,    dfs(a), 或者a=a*10+1,  dfs(a);如果a%n==0,就往回回溯,或者搜索的深度大于等于19的话,也要回溯。

 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<stack>
#include<algorithm>
using namespace std;
const int maxn=100005;
#define LL long long
int vis[maxn];
stack<int>s;
LL flag=0;
LL n;
void dfs(LL a,int t)
{
    if(t>=19)
    return ;
    if(flag)
        return ;
    if(a%n==0)
    {
        flag=1;
        printf("%lld\n",a);
        return ;
    }
    else
    {
        dfs(a*10,t+1);
        dfs(a*10+1,t+1);
    }

}
int main()
{
    while(~scanf("%lld",&n)&&n)
    {
        flag=0;
        dfs(1,0);

    }
    return 0;
}


 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值