hdu-1312

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38403    Accepted Submission(s): 23278


 

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

 

Sample Input
 
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

 

Sample Output
 
45 59 6 13
 
ac代码(dfs版本):
#include <iostream>
#include <stdio.h>
#include <vector>
#include <algorithm>
#include <iomanip>
#include <string>
using namespace std;

char chart[22][22];
int dis[4][2]={0, 1, 0, -1, 1, 0, -1, 0};

void dfs(int x, int y, int &ans, int m_x, int m_y){		//m_x表示横坐标的最大值
	if(x<0 || y<0 || x>=m_x || y>=m_y){
		return ;
	}
	if(chart[x][y]=='#')
		return ;
	if(chart[x][y]=='@'|| chart[x][y]=='.'){	   
		++ans;
		chart[x][y]='#';
		for(int i=0; i<4; ++i){
			dfs(x+dis[i][0], y+dis[i][1], ans, m_x, m_y);
		}
	}
}
int main(){
	int w=0, h=0, dx=0, dy=0;
	string str;
	while(cin >> w >> h){
		if(!w && !h)
			break;
		for(int i=0; i<h; ++i){
			cin >> str;
			for(int j=0; j<w; ++j){
				chart[i][j] = str[j];
				if(str[j]=='@'){		//x表示行坐标,y表示列坐标
					dx=i;
					dy=j;
				}
			}
		}	
		int ans=0;
		dfs(dx, dy, ans, h, w);
		cout << ans << endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值