PAT 甲级1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2

题目大意:
  给定两个多项式求他们的和, 且按照 k (有 k 项), 第一项的指数, 第一项的系数 这一格式输入。且注意到是按照指数不减次序输入的。要求输出也是 有 n 项 第一项的指数,第一项的系数;且按照指数不减的次数输出。

思路:
  创建一个double 变量的静态数组 ans,每次读入 指数 exp 与系数temp。 且进行 ans[exp] += temp 的操作,即将系数temp 加到 相应位置上。

参考代码:

#include<cstdio>
const int maxn = 1010;
double ans [maxn];
int main (){
	int n, exp;
	double temp;
	scanf("%d", &n);
	for(int i = 0; i < n; ++i){
		scanf("%d %lf", &exp, &temp);
		ans[exp] += temp;
	}
	scanf("%d", &n);
	for(int i = 0; i < n; ++i){
		scanf("%d %lf", &exp, &temp);
		ans[exp] += temp;
	}
	int cnt = 0;
	for(int i = 0; i < maxn; ++i)
		if(ans[i] != 0)	cnt++;
	printf("%d", cnt);
	for(int i = maxn - 1; i >= 0; --i)
		if(ans[i] != 0)	printf(" %d %.1f", i, ans[i]);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值