PAT 甲级1009 Product of Polynomials (25 分)

1009 Product of Polynomials 25 )

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN2 ... NK aNK

where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1K10, 0NK<<N2<N11000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

 

题目大意:

  求所给的两个多项式的乘积。每行均表示一个多项式, 第一个数字k代表该多项式有多少系数非零项,接下来的k组数字按照系数递减的顺序且每组数字由2个数字组成,分别为指数、系数。要求输出两个多项式相乘后的结果,结果也按照输入格式输出。

 

思路:

  第一组多项式最好用vector <结构体> 的方式分别存储指数与系数,否则就开一个数组double f[1001],第二组多项式不用存储,读入后直接处理,然后存储在double ans[2001](因为系数最大为2000  = 1000 + 1000)中。

  由于考虑到降低时间复杂度,在处理的时候记录maxidx(最大的系数)。

  注意,在统计ans的非零项的个数时,一定要所有多项式都处理完后再进行计数。有可能会想在处理的时候 用 if(ans[f[j]].exp + exp ) cnt++; (当两项相乘后,第一次新的系数则令个数 + 1)。这样处理的话,当系数有负时(测试点01)就会出错。所以应当在处理后再计数。

 

参考代码:

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
struct plnm{
	int exp;
	double cof;
};
vector<plnm> f;
double ans[2001];
int main(){
	int k;
	scanf("%d", &k);
	f.resize(k);
	for(int i = 0; i < k; ++i) scanf("%d %lf", &f[i].exp, &f[i].cof);
	scanf("%d", &k);
	int maxidx = -1, cnt = 0;
	for(int i = 0; i < k; ++i){
		int exp;
		double cof;
		scanf("%d %lf", &exp, &cof);
		for(int j = 0; j < f.size(); ++j){
			ans[f[j].exp + exp] += cof * f[j].cof;
			maxidx = max(maxidx, f[j].exp + exp);
		}
	}
	for(int i = maxidx; i >= 0; --i)
		if(ans[i])	cnt++;
	printf("%d %d %.1f", cnt, maxidx, ans[maxidx]);
	for(int i = maxidx - 1; i >= 0; --i)
		if(ans[i])	printf(" %d %.1f", i, ans[i]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值