PAT 1005 Spell It Right 翻译 分析 代码

28 篇文章 0 订阅
27 篇文章 0 订阅

我宣布,c++天下第一,真的是好简单,寥寥数语就把程序描绘的淋漓尽致。

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10^100^).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

 

#include<iostream>
using namespace std;
int main(){
	string a; //定义字符串a
	cin>>a;    //输入字符串
	int sum = 0,i;
	for( i =0;i<a.length() ;i++)
	{
		sum+=a[i]-'0';
	}
	string s = to_string(sum); 
	string acw[10]= {"zero","one","two","three","four","five","six","seven","eight","nine"};
	cout<<acw[s[0]-'0'];
	for(i=1;i<s.length() ;i++)
	{
		cout<<" "<<acw[s[i]-'0'];
	}
	return 0;
}

 接下来写一个c版本的,各位对比一下,到底哪个更方便一点。

#include<stdio.h>
#include<string.h>
int main(){
	char a[111];
	char s[20];
	char acw[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
	gets(a);
	int sum = 0,i;
	int len =strlen(a);
	for(i=0;i<len;i++){
		sum+=a[i]-'0';
	}
	sprintf(s,"%d",sum);//将sum以%d的格式写入字符类型s数组中 
	printf("%s",acw[s[0]-'0']);
	for(i=1;i<strlen(s);i++)
	{
		printf(" ");
		printf("%s",acw[s[i]-'0']);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值