PAT Advanced—1148 Werewolf - Simple Version (20分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,
player #1 said: “Player #2 is a werewolf.”;
player #2 said: “Player #3 is a human.”;
player #3 said: “Player #4 is a werewolf.”;
player #4 said: “Player #5 is a human.”; and
player #5 said: “Player #4 is a human.”.
Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?
Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.
Output Specification:
If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.
Sample Input 1:
5
-2
+3
-4
+5
+4
Sample Output 1:
1 4

Sample Input 2:
6
+6
+3
+1
-5
-2
+4
Sample Output 2 (the solution is not unique):
1 5

Sample Input 3:
5
-2
-3
-4
-5
-1
Sample Output 3:
No Solution

题目大意:
  给定N个玩家,其中有2个狼人,至少有1个但是不是所有的狼人都说谎,其中有两个人说谎,找出其中的狼人。若多种情况,输出序号最小的,没有这样的情况,输出"No Solution"。

思路:
  按升序遍历试探所有两个人为狼人的情况,保存说谎的人的信息,最后判断是否是两个人撒谎,且是否是一个狼人一个人类

注意:

  1. 说谎的判断条件v[k] * a[abs(v[k])] < 0,即与事实不符为相反数

代码:(C++)

#include<iostream>
#include<vector>
#include<cmath>

using namespace std;

int main()
{
	int n;
	cin>>n;
	vector<int> v(n+1);  //用于保存每个人的说法
	for(int i=1; i<=n; i++)
		cin>>v[i];
	for(int i=1; i<=n; i++)
	{
		//用的方法还是遍历,不停的试探,直到成功,顺序从小到大,符合直接输出就行
		//暂定i,j为狼人
		for(int j=i+1; j<=n; j++)
		{
			//lie用于存说话的人,a保存本次假定的狼人情况,1为人类,-1为狼人
   			vector<int> lie, a(n+1, 1);
			a[i] = a[j] = -1;  //把i,j当成狼人来试探
			for(int k=1; k<=n; k++)
   			{
   				//这个人说的话和假定的情况不同的话,说明它在说谎
   				//v[k]保存的是人员的编号,正负号说明是人还是狼人
   				//v[k]就是这个人此次的发言,a[abs(v[k])]是我们自己假设的情况
   				//只要这两个相乘异号,说明在这次假设中,这个人说谎,保存起来
				if(v[k] * a[abs(v[k])] < 0)
					lie.push_back(k);
			}
			//保证说谎的人只有两个,且是一个狼人一个人类,就可以输出结果了
			if(lie.size() == 2 && a[lie[0]] + a[lie[1]] == 0)
			{
				cout<<i<<" "<<j;
				return 0;
			}

		}
	}
	//所有情况都遍历完了,没有结果,输出无解
	cout<<"No Solution";

	return 0;
}

参考:
  https://www.liuchuo.net/archives/6494

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值