PAT甲级-1122-Hamiltonian Cycle(哈密顿回路)

The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1 V​2   V​n​​ 

where n is the number of vertices in the list, and V​i​​ 's are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

思路:

flag1标记:
①出发点和终点相同 (构成回路)
②顶点个数为图中总顶点个数+1 (经过所有顶点)
③除了首尾这对相同结点可以出现2次外,其余节点在环中只能经过1次
flag2标记:
判断这条路能不能走通

-----当falg1、flag2都为1时是哈密尔顿路径,否则不是!

代码如下

#include<iostream>
#include<vector>
#include<set>
const int N = 205;
using namespace std;
int graph[N][N];
int main()
{
	int n,m,k,x,y,num;
	cin>>n>>m;
	fill(graph[0],graph[0]+N*N,0);
	while(m--){
		cin>>x>>y;
		graph[x][y] = graph[y][x] = 1;
	}
	cin>>k;
	while(k--){
		cin>>num;
		vector<int> v(num);
		set<int> s;
		int flag1=1,flag2=1;
		for(int i = 0; i < num; i++){
			cin>>v[i];
			s.insert(v[i]);
		}
		if(s.size()!=n||num != n+1 || v[0] != v[num-1]) flag1 = 0;
		for(int i = 0; i < num-1; i++){
			if(graph[v[i]][v[i+1]] == 0) flag2 = 0;
		}
		printf("%s", flag1&&flag2?"YES\n":"NO\n");
	}
	return 0;
}
  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值