Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input :
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output :
24
- 注意:如果采用一维数组下标来标记颜色,值表示次数的话,会发生溢出,因为2的24次方为16 777 216,是一个极大的数,用它做数组下标会溢出,因此用map!
代码如下
#include<iostream>
#include<map>
using namespace std;
int main()
{
int m,n;
scanf("%d %d", &m, &n);
map<int ,int> arr;
int half = m*n/2;
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
int tmp;
scanf("%d", &tmp);
arr[tmp]++;
if(arr[tmp] > half){
printf("%d", tmp);
return 0;
}
}
}
return 0;
}