点击链接PAT甲级-AC全解汇总
题目:
Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224 ). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
题意:
输入一对数字,找出次数最多的数字
我的代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
map<int,int>times;
int M,N,res=0;
cin>>M>>N;
for(int i=0;i<N;i++)
{
for(int j=0;j<M;j++)
{
int num;
cin>>num;
if(times[num])times[num]++;
else times[num]=1;
res=times[num]>times[res]?num:res;
}
}
cout<<res<<endl;
return 0;
}