hdu6187 Destroy Walls(最小生成树+思维)

题目链接
Problem Description
Long times ago, there are beautiful historic walls in the city. These walls divide the city into many parts of area.

Since it was not convenient, the new king wants to destroy some of these walls, so he can arrive anywhere from his castle. We assume that his castle locates at (0.6∗2√,0.6∗3√).

There are n towers in the city, which numbered from 1 to n. The ith’s location is (xi,yi). Also, there are m walls connecting the towers. Specifically, the ith wall connects the tower ui and the tower vi(including the endpoint). The cost of destroying the ith wall is wi.

Now the king asks you to help him to divide the city. Firstly, the king wants to destroy as less walls as possible, and in addition, he wants to make the cost least.

The walls only intersect at the endpoint. It is guaranteed that no walls connects the same tower and no 2 walls connects the same pair of towers. Thait is to say, the given graph formed by the walls and towers doesn’t contain any multiple edges or self-loops.

Initially, you should tell the king how many walls he should destroy at least to achieve his goal, and the minimal cost under this condition.

Input
There are several test cases.

For each test case:

The first line contains 2 integer n, m.

Then next n lines describe the coordinates of the points.

Each line contains 2 integers xi,yi.

Then m lines follow, the ith line contains 3 integers ui,vi,wi

|xi|,|yi|≤105

3≤n≤100000,1≤m≤200000

1≤ui,vi≤n,ui≠vi,0≤wi≤10000

Output
For each test case outout one line with 2 integers sperate by a space, indicate how many walls the king should destroy at least to achieve his goal, and the minimal cost under this condition.

Sample Input
4 4
-1 -1
-1 1
1 1
1 -1
1 2 1
2 3 2
3 4 1
4 1 2

Sample Output
1 1

Source
2017ACM/ICPC广西邀请赛-重现赛(感谢广西大学)
思路:给出n个点的坐标根本没有任何意义。。。
可以先求出最大生成树,边的总数减去最大生成树的条数,边的总和减去最大生成的边权和就是答案。。。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e6+1;
int n,m,father[maxn];
struct node{
    int u,v,w;
}s[maxn];
int findfather(int x)
{
    if(x==father[x]) return x;
    int i=findfather(father[x]);
    father[x]=i;
    return i;
}
bool cmp(const node &a,const node &b)
{
    return a.w>b.w;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int cnt=0,x,y;
        ll ans=0,sum=0;
        for(int i=1;i<=n;++i) scanf("%d%d",&x,&y);
        for(int i=0;i<=n;++i) father[i]=i;
        for(int i=1,u,v,w;i<=m;++i)
        {
            scanf("%d%d%d",&s[i].u,&s[i].v,&s[i].w);
            sum+=s[i].w;
        }
        sort(s+1,s+1+m,cmp);
        for(int i=1;i<=m;++i)
        {
            int fa=findfather(s[i].u),fb=findfather(s[i].v),w=s[i].w;
            if(fa!=fb)
            {
                cnt++;
                father[fa]=fb;
                ans+=w;
                if(cnt==n-1) break;
            }
        }
        printf("%d %lld\n",m-cnt,sum-ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值