ZOJ2136 Longest Ordered Subsequence(最长上升子序列)(nlog版)

题目链接
A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, the sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e.g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences of this sequence are of length 4, e.g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input contains the length of sequence N (1 <= N <= 1000). The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces.

Output

Output must contain a single integer - the length of the longest ordered subsequence of the given sequence.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input

1

7
1 7 3 5 9 4 8

Sample Output

4
思路:模板题,这里学一下nlog的做法。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e5+1;
const int inf=0x3f3f3f3f;
int dp[maxn],x[maxn],a[maxn];
int main()
{
	int T,n,cas=0;
	scanf("%d",&T);
	for(int j=1;j<=T;++j)
	{
		if(cas) printf("\n");
        else cas=1;
		scanf("%d",&n);
		for(int i=1;i<=n;++i) scanf("%d",&a[i]),x[i]=inf;
		for(int i=1;i<=n;++i)
		{
			int pos=lower_bound(x+1,x+1+n,a[i])-x;
			x[pos]=a[i];
			dp[i]=pos;
		}
		int ans=0;
		for(int i=1;i<=n;++i) ans=max(ans,dp[i]);
		printf("%d\n",ans);
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值