Break Standard Weight ZOJ - 3706

The vast power system is the most complicated man-made system and the greatest engineering innovation in the 20th century. The following diagram shows a typical 14 bus power system. In real world, the power system may contains hundreds of buses and thousands of transmission lines.

Network topology analysis had long been a hot topic in the research of power system. And network density is one key index representing the robustness of power system. And you are asked to implement a procedure to calculate the network density of power system.

The network density is defined as the ratio between number of transmission lines and the number of buses. Please note that if two or more transmission lines connecting the same pair of buses, only one would be counted in the topology analysis.

Input

The first line contains a single integer T (T ≤ 1000), indicating there are T cases in total.

Each case begins with two integers N and M (2 ≤ NM ≤ 500) in the first line, representing the number of buses and the number of transmission lines in the power system. Each Bus would be numbered from 1 to N.

The second line contains the list of start bus number of the transmission lines, separated by spaces.

The third line contains the list of corresponding end bus number of the transmission lines, separated by spaces. The end bus number of the transmission lines would not be the same as the start bus number.

Output

Output the network density of the power system in a single line, as defined in above. The answer should round to 3 digits after decimal point.

Sample Input

3
3 2
1 2
2 3
2 2
1 2
2 1
14 20
2 5 3 4 5 4 5 7 9 6 11 12 13 8 9 10 14 11 13 13
1 1 2 2 2 3 4 4 4 5 6 6 6 7 7 9 9 10 12 14

Sample Output

0.667
0.500
1.429

题意: T:案例数, 第一行:公交车数,路线的数目,第二行是公交车的起点,第三行是对应公交车的终点。计算所通路线数与公交车数的比值。(注意:a->b  和b->a 为同一条线)。


#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<cmath>
#include<cctype>
#include<stack>
#include<cstring>
#include<set>
#include<map>
using namespace std;
const int maxn = 100010;
typedef long long ll;
int vis[505][505];
int mapp1[505], mapp2[505];
int main()
{
    int n, t, m;
    scanf("%d", &t);
    while(t--)
    {
        memset(vis, 0, sizeof(vis));
        memset(mapp1, 0, sizeof(mapp1));
        memset(mapp2, 0, sizeof(mapp2));
        scanf("%d%d", &n, &m);
        //输入起点;
        for(int i=0; i<m; i++)
        {
            scanf("%d", &mapp1[i]);
        }
        //输入终点;
        for(int i=0; i<m; i++)
        {
            scanf("%d", &mapp2[i]);
        }
        int sum = 0;
        for(int i=0; i<m; i++)
        {
            if(!vis[mapp1[i]][mapp2[i]])
            {
                vis[mapp1[i]][mapp2[i]] = vis[mapp2[i]][mapp1[i]] = 1;//标记所通路线;
                sum++;
            }
        }
        printf("%.3lf\n", double(sum)/n);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值