K-Nice ZOJ - 3212

This is a super simple problem. The description is simple, the solution is simple. If you believe so, just read it on. Or if you don't, just pretend that you can't see this one.

We say an element is inside a matrix if it has four neighboring elements in the matrix (Those at the corner have two and on the edge have three). An element inside a matrix is called "nice" when its value equals the sum of its four neighbors. A matrix is called "k-nice" if and only if k of the elements inside the matrix are "nice".

Now given the size of the matrix and the value of k, you are to output any one of the "k-nice" matrix of the given size. It is guaranteed that there is always a solution to every test case.

Input

The first line of the input contains an integer T(1 <= T <= 8500) followed by T test cases. Each case contains three integers nmk (2 <= nm<= 15, 0 <= k <= (n - 2) * (m - 2)) indicating the matrix size n * m and it the "nice"-degree k.

Output

For each test case, output a matrix with n lines each containing m elements separated by a space (no extra space at the end of the line). The absolute value of the elements in the matrix should not be greater than 10000.

Sample Input

2
4 5 3
5 5 3

Sample Output

2 1 3 1 1
4 8 2 6 1
1 1 9 2 9
2 2 4 4 3
0 1 2 3 0
0 4 5 6 0
0 0 0 0 0
0 0 0 0 0
0 0 0 0 0

题意: 构造出一个含k个nice的n*m的矩阵。nice表示的是:周围4个数字之和等于该数字(边缘的数字不符合,因为他们周围不够四个字符)。

思路:答案有无数种,所以取最简单的就是:0的四周的数字为0,其余用1覆盖。


#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<cmath>
#include<cctype>
#include<stack>
#include<cstring>
#include<set>
using namespace std;
int mapp[20][20];
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n, m, k;
        scanf("%d%d%d", &n, &m, &k);
        memset(mapp, -1, sizeof(mapp));//初始化为-1;

        //矩阵本来是从0到n-1,除去矩阵边缘的数字,即从1到n-2;
        for(int i=1; i<n-1; i++)
        {
            for(int j=1; j<m-1; j++)
            {
                if(k<=0)
                    break;
                if(mapp[i][j]<=0)
                {
                    mapp[i][j] = 0;//本身为0;
                    mapp[i-1][j] = 0;//上边为0;
                    mapp[i+1][j] = 0;//下边为0;
                    mapp[i][j-1] = 0;//左边为0;
                    mapp[i][j+1] = 0;//右边为0;
                    k--;
                }
            }
            if(k<=0)
                break;
        }

        //如果没有构造为0即还是初始化的-1,那么最后就让他为1;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                if(mapp[i][j]<0)
                    mapp[i][j] = 1;
            }
        }

        //按照格式输出矩阵;
        for(int i=0; i<n; i++)
        {
            printf("%d", mapp[i][0]);
            for(int j=1; j<m; j++)
            {
                printf(" %d", mapp[i][j]);
            }
            printf("\n");
        }

    }
    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值