Let's Chat

ACM (ACMers' Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described as follows:

If two users, A and B, have been sending messages to each other on the last mconsecutive days, the "friendship point" between them will be increased by 1 point.

More formally, if user A sent messages to user B on each day between the (i - m + 1)-th day and the i-th day (both inclusive), and user B also sent messages to user A on each day between the (i - m + 1)-th day and the i-th day (also both inclusive), the "friendship point" between A and B will be increased by 1 at the end of the i-th day.

Given the chatting logs of two users A and B during n consecutive days, what's the number of the friendship points between them at the end of the n-th day (given that the initial friendship point between them is 0)?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T≤ 10), indicating the number of test cases. For each test case:

The first line contains 4 integers n (1 ≤ n ≤ 109), m (1 ≤ m ≤ n), x and y (1 ≤ x, y ≤ 100). The meanings of n and m are described above, while x indicates the number of chatting logs about the messages sent by A to B, and y indicates the number of chatting logs about the messages sent by B to A.

For the following x lines, the i-th line contains 2 integers la, i and ra, i (1 ≤ la,i ≤ ra, i ≤ n), indicating that A sent messages to B on each day between the la, i-th day and the ra, i-th day (both inclusive).

For the following y lines, the i-th line contains 2 integers lb, i and rb, i (1 ≤ lb,i ≤ rb, i ≤ n), indicating that B sent messages to A on each day between the lb, i-th day and the rb, i-th day (both inclusive).

It is guaranteed that for all 1 ≤ i < x, ra, i + 1 < la, i + 1 and for all 1 ≤ i < y, rb, i + 1 < lb, i + 1.

Output

For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of the n-th day.

Sample Input

2
10 3 3 2
1 3
5 8
10 10
1 8
10 10
5 3 1 1
1 2
4 5

Sample Output

3
0

Hint

For the first test case, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th, 6th, 7th, 8th and 10th day. As m = 3, the friendship points between them will be increased by 1 at the end of the 3rd, 7th and 8th day. So the answer is 3.


题意:输入 n, m, x, y。n表示一共的天数,m表示持续m天互发消息友情值才可以+1;x, y分别代表A->B与B->A的连续时间段数。 输出最后的友情值。


#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<cmath>
#include<cctype>
#include<stack>
#include<cstring>
#include<set>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 1e4;
const int mod = int(1e9) + 7;
int a[maxn];
//l, r分别代表时间段的左右端点;
struct node
{
    long long l,r;
};
int main()
{
	int t ;
	cin>>t;
	while(t--)
    {
        int n,m,x,y;
        cin>>n>>m>>x>>y;
        node a[1000],b[1000];
        //输入A->B的时间段的左右端点;
        for(int i=1;i<=x;i++)
            cin>>a[i].l>>a[i].r;
        //输入B->A的时间段的左右端点;
        for(int i=1;i<=y;i++)
            cin>>b[i].l>>b[i].r;
        int ans=0;
        
        for(int i=1;i<=x;i++)
        {
            for(int j=1;j<=y;j++)
            {
                //如果该a区间的右端点比该b区间的左端点还要小,a区间整体在b区间左侧,说明该a区间不可能与b以及下一个b区间有交集,直接跳出j循环;
                if(a[i].r<b[j].l)
                    break;

                //如果该a区间的左端点比该b区间的右端点大,a区间整体在b区间右侧,说明该a区间与该b区间无交集,但是不能说明与下一个b区间无交集,所以进行下一个j循环;
                if(a[i].l>b[j].r)
                    continue;

                //如果两个区间有交集,那么,左边界取较大值,右边界取较小值;
                else
                {
                    int L=max(a[i].l,b[j].l);
                    int R=min(a[i].r,b[j].r);
                    int s=R-L+1;//s即为区间包含天数;
                    //ans即为友情值, 连续天数超过m后不清空;
                    if(s>=m)
                    {
                        ans=ans+s-m+1;
                    }
                }
            }
        }
        cout<<ans<<endl;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值