Draw Something Cheat ZOJ - 3603

Have you played Draw Something? It's currently one of the hottest social drawing games on Apple iOS and Android Devices! In this game, you and your friend play in turn. You need to pick a word and draw a picture for this word. Then your friend will be asked what the word is, given the picture you have drawn. The following figure illustrates a typical scenario in guessing the word.

word guessing in draw something

As you see, when guessing a word you will be given the picture and 12 letters. You must pick some of these letters to form a word that matches the picture. Each letter can only be used once. It is a lot of fun if your friend is a talented painter, but unfortunately some drawings from your friend are totally incomprehensible. After several times of becoming mad by the drawings, you find a way to cheat in the game.

In this game, letters not included in the correct answer are randomly generated. If you cannot find the correct answer when guessing, you can write down all the letters and restart the game. Then you would find some of these letters are changed. Of course these changed letters will never appear in the answer. By eliminating these letters you are a step closer to the answer.

So In this problem, you need to write a program to automate the cheating process. Given N strings of letters to the same picture, you need to eliminate as many letters as possible, and output the remaining letters.

Input

There are multiple test cases. The first line of the input is an integer T ≈ 1000 indicating the number of test cases.

Each test case begins with a positive integer N≤ 20 indicating the number of times you have entered the game. Then N lines follow. Each line is a string of exactly 12 uppercase letters, indicating the candidate letters in one guess. It is guaranteed that the answer has at least 1 letter and has no more than 12 letters.

Output

For each test case, output the remaining letters in alphabet order after the process described above. One line for each test case.

Sample Input

2
2
ABCDEFGHIJKL
ABCDEFGHIJKL
2
SAWBCVUXDTPN
ZQTLFJYRCGAK

Sample Output

ABCDEFGHIJKL
ACT

题意: T:案例个数。n:数组数。输出这n个数组中每个数组都出现的字符。


#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<queue>
#include<cmath>
#include<cctype>
#include<stack>
#include<cstring>
using namespace std;
int t;
char mapp[1000];
int suma[100];
int sumi[100];
int n;
int main()
{
    scanf("%d", &t);
    while(t--)
    {
        memset(mapp, 0, sizeof(mapp));
        memset(suma, 0, sizeof(suma));
        memset(sumi, 0, sizeof(sumi));
        scanf("%d", &n);
        scanf("%s", mapp);//输入第一个字符串;
        int len = strlen(mapp);
        //记录第一个字符串中每个字母出现的次数;
        for(int i=0; i<len; i++)
        {
            suma[mapp[i]-'A']++;
        }
        //输入剩下的n-1个字符串,同样记录其每个字符出现的次数;
        for(int i=1; i<n; i++)
        {
            memset(sumi, 0, sizeof(sumi));
            scanf("%s", mapp);
            len = strlen(mapp);
            for(int j = 0; j<len; j++)
            {
                sumi[mapp[j]-'A']++;
            }
            //遍历26个字符,使每个字符的次数等于所有字符串对应字符出现次数最少的那个;
            for(int j=0; j<26; j++)
            {
                if(suma[j]>sumi[j])
                    suma[j] = sumi[j];
            }
        }
        //输出符合规定的字符;
        for(int i=0; i<26; i++)
        {
            while(suma[i]--)
            {
                printf("%c", i+'A');
            }
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值