PAT 1020 Tree Traversals (25分)

题目:
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

解题思路:
这是一个关于二叉树的数据结构考点,通过题目给出的中序遍历序列和后序遍历序列来重建二叉树,然后再通过层次遍历二叉树输出。

代码如下:

#include<stdio.h>
#include<queue>
#include<cstring>
#include<iostream>
using namespace std;

struct TreeNode
{
	TreeNode* left;
	TreeNode* right;
	int data;
};

int N;
int postorder[32];
int inorder[32];

struct TreeNode* CreateTree(int* a,int* b,int n) {
	TreeNode* root;
	root = (TreeNode*)malloc(sizeof(TreeNode));
	if (n <= 0)
		return NULL;
	root->data = a[n - 1];
	int *p;
	for (p = b; *p != -1; p++) {
		if (*p == a[n - 1]) //在中序遍历中找到与根节点相等的值
			break;
	}
	/*从中序序列中的p位置分为左子树和右子树,依次递归*/
	int t = p - b;
	root->left = CreateTree(a, b, t);
	root->right = CreateTree(a + t, b + t + 1, n - t - 1);
	return root;
}

int main() {
	TreeNode* r;
	memset(postorder, -1, sizeof(postorder));
	memset(inorder, -1, sizeof(inorder));
	cin >> N;
	for (int i = 0; i < N; i++) {
		cin >> postorder[i];
	}
	for (int i = 0; i < N; i++) {
		cin >> inorder[i];
	}
	r = CreateTree(postorder, inorder, N);
	queue<TreeNode*> q;
	q.push(r);
	/*层序遍历输出*/
	while (!q.empty()) {
		TreeNode* node = q.front();
		if (node->left != NULL) q.push(node->left);
		if (node->right != NULL) q.push(node->right);
		q.pop();
		if (q.empty())
			cout << node->data;
		else
			cout << node->data << " ";
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值