Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
#include "iostream"
using namespace std;
int main() {
int a, b;
cin >> a >> b;
int sum = a + b;
int ans[110];
int count = 0;
if (sum == 0) cout << 0;
if (sum < 0) {
cout << "-";
sum = -sum;
}
while (sum != 0) {
ans[count++] = sum % 10;
sum /= 10;
}
for (int i = count - 1; i >= 0; i--) {
cout << ans[i];
if (i % 3 == 0 && i != 0) {
cout << ",";
}
}
}