1001 A+B Format (20分)

本文介绍了一个简单的程序,用于计算两个整数a和b的和,并将结果以标准格式输出,即使用逗号作为千位分隔符。程序首先读取输入的两个整数,计算它们的和,然后将和转换为带有逗号分隔的字符串格式进行输出。此程序适用于处理范围在-10^6到10^6之间的整数。
摘要由CSDN通过智能技术生成

 

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 

#include "iostream"

using namespace std;

int main() {
    int a, b;
    cin >> a >> b;
    int sum = a + b;
    int ans[110];
    int count = 0;
    if (sum == 0) cout << 0;
    if (sum < 0) {
        cout << "-";
        sum = -sum;
    }
    while (sum != 0) {
        ans[count++] = sum % 10;
        sum /= 10;
    }
    for (int i = count - 1; i >= 0; i--) {
        cout << ans[i];
        if (i % 3 == 0 && i != 0) {
            cout << ",";
        }
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值