The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth.
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.
Output
Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.
Sample Input
2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######
Sample Output
Maximum rope length is 0.
Maximum rope length is 8.
Hint
Huge input, scanf is recommended.
If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc
题意:给你一个N*M的迷宫,迷宫里面有' # '和 ' . ' 两种字符,问你距离最远的两个' . '之间的距离。
读懂题意就很简单了, 就是在迷宫图里面用二维来模拟一维求树的直径。两次BFS就行了。
思路:首先找到任意一个' . '的坐标(x1, y1),然后以该坐标为起点BFS整个迷宫找最长路,找到该坐标对应最长路的终点(x2, y2)。再以(x2, y2)为起点BFS整个迷宫找最长路即可。
AC代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
const int MAXN=1e3+50;
int n,m,sum;
char str[MAXN][MAXN];
bool vis[MAXN][MAXN];
int d[4][2]={0,1,0,-1,1,0,-1,0};
int a,b;
struct node{
int x,y;
int s;
}e1,e2;
bool check(int x,int y){
return x<0||x>=n||y<0||y>=m||vis[x][y]==1||str[x][y]=='#';
}
void BFS(int x,int y){
queue<node > q;
memset(vis,0,sizeof(vis));
e1.x=x,e1.y=y,e1.s=0;
q.push(e1);
sum=0;
while(!q.empty()){
e1=q.front();
q.pop();
for(int i=0;i<4;i++)
{
e2.x = e1.x + d[i][0];
e2.y = e1.y + d[i][1];
e2.s=e1.s+1;
if(!check(e2.x,e2.y)){
vis[e2.x][e2.y]=1;
if(e2.s>sum){
sum=e2.s;
a=e2.x;
b=e2.y;
}
q.push(e2);
}
}
}
}
int main(){
int t;
cin>>t;
while(t--){
memset(str,0,sizeof(str));
cin>>m>>n;
bool flag=0;
for(int i=0;i<n;i++){
scanf("%s",str[i]);
if(flag) continue;
for(int j=0;j<m;j++){
if(str[i][j]=='.') {
a=i;
b=j;
flag=1;
}
}
}
BFS(a,b);
BFS(a,b);
printf("Maximum rope length is %d.\n",sum);
}
return 0;
}