1001 A+B Format (20 分)

1001 A+B Format (20 分)

整体的梳理

主要是对于整形的数字如何快速且简单的输出其数位上的数字,并且合理的将加和的结果以三个字符为一个片段输出

完整的题目介绍

1.content

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

2.inuput

Each input file contains one test case. Each case contains a pair of integers a and b where −10^6​​ ≤a,b≤10^​6 . The numbers are separated by a space.

3.output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

4.sample input

-1000000 9

5.sample output

-999,991

代码展示

#include<iostream>
#include<string>
#include<cmath>
#include<sstream>
using namespace std;
//总结 主要是将整形的数位上的数字输出转化为字符串中char型的输出 
//运用到的 string str;  stringstream st;//设置字符串的输入流 st << abs(sum);//绝对值化且输入到字符串的输入流之中 str = st.str();//取出字符流中缓存的数据 
int main()
{
    int a, b, sum;
    string str;
    stringstream st;//设置字符串的输入流 
    cin >> a >> b;
    sum = a + b;
    if (sum < 0)cout << '-';//对于负值情况的设定 
    st << abs(sum);//绝对值化且输入到字符串的输入流之中 
    str = st.str();//取出字符流中缓存的数据 
    int len = str.size();
    int n = len / 3;//看看有完整几个片段(三个数字作为一个片段) 
    int m = len % 3;//溢出的不完整的片段的字符片段 
    if (m == 1)cout << str[0];
    else if (m == 2)cout << str[0] << str[1];
    else if (m==0)cout << str[0] << str[1] << str[2]; 
    int flag = (m>0?m:3)-1;//在这里记录的是已经输出的字符流的序号标签 
    while (flag<len-1)
    {
        cout << ",";
        for (int i = 1; i <= 3; i++)
        {
            cout << str[flag+i];//不断的输出完整片段里的字符 
        }
        flag += 3;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值