PAT1001 A+B Format C语言

1001 A+B Format (20)(20 分)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

解题分析:

这道题我最开始提交的时候发现只有15分有部分错误,那部分错误在哪呢。认真再分析了题目后发现如果不判断后面的数字中是否含有0,就会造成0输出被省掉的错误比如:100000 1 本应该输出 100,001但是如果不判断的话输出为100,1就会产生错误。为了方便后面判断及输出可以采取一部分一部分的输出。

代码:#include<stdio.h>
int main()
{
int a,b,sum,t,k;
scanf("%d%d",&a,&b);
sum=a+b;
if(sum<1000&&sum>-1000)
printf("%d\n",sum);
else
{t=sum%1000;
if(t<0)t=t*-1;
sum=sum/1000;
if(sum<1000&&sum>-1000)
{if(t<10)
    printf("%d,00%d\n",sum,t);
else if(t<100)
    printf("%d,0%d\n",sum,t);
else if(t>100)
    printf("%d,%d\n",sum,t);
}
else
{k=sum%1000;
if(k<0)k=k*-1;
sum=sum/1000;
printf("%d,",sum);
if(k<10)
    printf("00%d,",k);
else if(k<100)
    printf("0%d,",k);
else if(k>100)
    printf("%d\n",k);
if(t<10)
    printf("00%d\n",t);
else if(t<100)
    printf("0%d\n",t);
else if(t>100)
    printf("%d\n",t);
}
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值