PAT 甲级 1015(Reversible Primes)

题目要求

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 1 0 5 10^5 105 ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

翻译

输入为10进制数,后面跟一个数是需要转换的进制,我们需要通过这个进制转换倒序还原另一个数,如果两个数都是素数则输出“Yes”,否则“No”

代码

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int trans(int n,int d)//转换进制
{
    int num[100001];
    int m=n,j=0,sum=0;
    while(m!=0)
    {
        num[j++]=m%d;
        m=m/d;
    }
    int k=0;
    for(int i=j-1;i>=0;i--)
    {
        sum+=num[i]*pow(d,k++);
    }
    return sum;
}
bool judge(int num)//判断是否为素数
{
    if(num<=1) return 0;//其中一个测试点需要
    for(int i=2;i<=sqrt(num);i++)
    {
        if(num%i==0)
            return 0;
    }
    return 1;
}
int main()
{
    int n,d;
    cin>>n;
    while(n>=0)
    {
        cin>>d;
        int x = trans(n,d);
        if(judge(x)&&judge(n)){
            cout<<"Yes"<<endl;
        }else{
            cout<<"No"<<endl;
        }
        cin>>n;
    }
    system("pause");
}

思路

第一步是如何输入,题意是输入为负数时停止,则使用while语句
第二步,进制数转换,具体可看以上代码trans()函数
第三步,判断素数,这个比较简单,但是有一个测试点是需要判断小于等于1的情况,需要注意!!!
如此,完成。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值