PAT 甲级 1020(Tree Traversals )

题目要求

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

翻译

分别输入后序和中序的树,要求输出层次遍历的结果

代码

#include<iostream>
#include<queue>
using namespace std;

struct node
{
    int value;
    node* left, *right;
};

//inorder 中序
//postorder 后序
//preorder 前序
int post[40],in[40];
node* makenode(int h1,int t1,int h2,int t2)
{
    if(h1>t1) return NULL;
    node *p=new node;
    p->value = post[t1];
    int index;
    for(index = h2;in[index]!=post[t1];index++);
    p->left = makenode(h1,index-1-h2+h1,h2,index-1);
    p->right = makenode(index-h2+h1,t1-1,index+1,t2);
    return p;
}
int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++) cin>>post[i];
    for(int i=0;i<n;i++) cin>>in[i];
    node*root= makenode(0,n-1,0,n-1);
    //层序遍历
    queue<node*> q;
    q.push(root);
    int i;
    while (!q.empty())
    {
        if(i!=0) cout<<" ";
        i++;
        node *front =q.front();
        cout<<front->value;
        q.pop();
        if(front->left!=nullptr) q.push(front->left);
        if(front->right!=nullptr) q.push(front->right);
    }
    system("pause");
}

思路

根据二叉树的后序、中序构建一个二叉树,然后输出它的层次序列

采用递归,会更容易建立二叉树

层序遍历用队列

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值