Is It A Tree?

Is It A Tree?

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
在这里插入图片描述

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

树(tree)是包含n(n>=0)个结点的有穷集,其中:
(1)每个元素称为结点(node);
(2)有一个特定的结点被称为根结点或树根(root)。
(3)除根结点之外的其余数据元素被分为m(m≥0)个互不相交的集合T1,T2,……Tm-1,其中每一个集合Ti(1<=i<=m)本身也是一棵树,被称作原树的子树(subtree)。

单个结点是一棵树,树根就是该结点本身
空集合也是树,称为空树。空树中没有结点。

它具有以下的特点:
每个结点有零个或多个子结点;
没有父结点的结点称为根结点;非空树有且仅有一个根
每一个非根结点有且只有一个父结点;
除了根结点外,每个子结点可以分为多个不相交的子树; 树中没有环

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1005;//为什么开这么大,我也不知道 
int pre[maxn];
bool book[maxn],flag;
int find(int x){
	return x==pre[x]?x:pre[x]=find(pre[x]);
}
void merge(int x,int y){
	int fx=find(x);
	int fy=find(y);
	if(fx==fy||fy!=y) //有环或者某个结点有不止一个父亲
	flag=false;
	else if(fx!=fy){
	pre[fy]=fx;	 //x是y的祖先 
	book[x]=true;
	book[y]=true;
	}

}
int main(){
	int x,y,k=0;
	while(scanf("%d%d",&x,&y)){
		if(x==-1&&y==-1) break;//poj能过,hdu会超时(改成  if(x<0&&y<0) break;  能过)
		if(x==0&&y==0){      //空树 
			printf("Case %d is a tree.\n",++k);
			continue;
		}
		
		memset(book,0,sizeof(book));        //初始化 标记数组 
		for(int i=1;i<maxn;i++)             //初始化 各结点祖先 
		pre[i]=i;
		flag=true;                          //初始化判断标志 
		int root=0;                         //初始化根的个数 
		
		merge(x,y);	
		while(scanf("%d%d",&x,&y)){
			if(x==0&&y==0) break;
			merge(x,y);
		}
				
		if(!flag){                             //有环或者某个结点有不止一个个父亲 
		printf("Case %d is not a tree.\n",++k);
		continue;
		} 	
			
		for(int i=1;i<maxn;i++){
			if(book[i]){
				if(pre[i]==i) root++;
				if(root>1){        //有多个根 
					flag=false;
					break;
				}
			}
		}		
		if(!flag) printf("Case %d is not a tree.\n",++k);   //有多个根 
		else printf("Case %d is a tree.\n",++k);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值