Til the Cows Come Home

Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

  • Line 1: Two integers: T and N

  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.
    Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90
    Hint
    INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

题意:一个人从n位置到1位置,输出最短路的权值是多少?
注意:该题为无向图,用邻接表存图的时候要双向存

#include<cstdio>
#include<vector>
#include<queue> 
#include<cstring>
using namespace std;
const int Inf=999999999; 
struct node{  //邻接表存图时用 
	int v,w;//后继结点与权值 
	node(){}
	node(int vv,int ww){
		v=vv;
		w=ww;
	} 	
};
struct Node{  //优先级队列用 
	int u,w;//前驱结点与权值
    Node(){}
	Node(int uu,int ww) {
		u=uu;
		w=ww;
	}
	bool operator<(const Node other)const{
	return w>other.w;
	}
};
const int N=1005;
int book[N],dis[N];
int t,n;
vector<node> G[N];
void SPFA(){
	priority_queue<Node> p;
	memset(book,0,sizeof(book));//清空标记  
	for(int i=1;i<=n;i++)
	dis[i]=Inf;//1到各点的距离初始化为无穷大 
	dis[1]=0;
	p.push(Node(1,dis[1]));
	while(!p.empty()){
		Node temp=p.top();
		p.pop();
		int u=temp.u;//中转点 
		if(book[u]) continue;
		book[u]=1;
		for(int i=0;i<G[u].size();i++){
			node tv=G[u][i];
			int v=tv.v;
			int w=tv.w;
			if(dis[v]>dis[u]+w){
				dis[v]=dis[u]+w;
				p.push(Node(v,dis[v]));
			}
		}
	}
	printf("%d\n",dis[n]);
}
int main(){
	while(~scanf("%d%d",&t,&n)){
		int u,v,w;
		while(t--){
		scanf("%d%d%d",&u,&v,&w); 
		G[u].push_back(node(v,w)); //双向图 
		G[v].push_back(node(u,w));
		}
		SPFA();	
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值