Number Sequence (KMP匹配模板)

https://cn.vjudge.net/problem/HDU-1711

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1
#include<bits/stdc++.h> 
using namespace std;
const int N=4e5+5;
int a[1000005],b[10005];
int Next[N];
void getNext(int s[],int len){
	int j=-1;
	Next[0]=-1;
	for(int i=1;i<len;i++){
		while(j!=-1&&s[i]!=s[j+1]) j=Next[j];
		if(s[i]==s[j+1]) j++;
		Next[i]=j;
	}
}
//KMP算法  判断pattern是否是text的子串 
int KMP(int text[],int n,int pattern[],int m) {
    //int n = strlen(text); m = strlen(pattern);
    getNext(pattern,m);    //计算pattern的Next数组 
    int j = -1;   
    for(int i = 0; i < n; i++){
        while(j != -1 && text[i] != pattern[j+1]){            
            j = Next[j];  //j回退使得满足条件或回到原点 
        }
        if(text[i] == pattern[j+1]){
            j++;   //匹配成功,j指向已匹配的最后一位             
        }
        if(j == m-1){
            return i-(m-1)+1;   //已全部匹配完成 
        }        
    } 
    return -1;  //匹配结束,失败       
}

int main(){
    int T;
	scanf("%d",&T);
	while(T--){
		int n,m;
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++) scanf("%d",&a[i]);
		for(int j=0;j<m;j++) scanf("%d",&b[j]);
		int ans=KMP(a,n,b,m); 
		printf("%d\n",ans);
	} 
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值