Simple String Problem (状压dp)

https://cn.vjudge.net/contest/312854#problem/I

Recently, you have found your interest in string theory. Here is an interesting question about strings.

You are given a string S of length n consisting of the first k lowercase letters.

You are required to find two non-empty substrings (note that substrings must be consecutive) of S, such that the two substrings don't share any same letter. Here comes the question, what is the maximum product of the two substring lengths?

Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, the first line consists of two integers n and k. (1 <= n <= 2000, 1 <= k <= 16).

The second line is a string of length n, consisting only the first k lowercase letters in the alphabet. For example, when k = 3, it consists of a, b, and c.

Output

For each test case, output the answer of the question.

Sample Input

4
25 5
abcdeabcdeabcdeabcdeabcde
25 5
aaaaabbbbbcccccdddddeeeee
25 5
adcbadcbedbadedcbacbcadbc
3 2
aaa

Sample Output

6
150
21
0

Hint

One possible option for the two chosen substrings for the first sample is "abc" and "de".

The two chosen substrings for the third sample are "ded" and "cbacbca".

In the fourth sample, we can't choose such two non-empty substrings, so the answer is 0.

题意:给定一个字符串,由前k个小写字母组成,取两个子串,其中一个子串内的字母不与另一个子串内任何字母相同,求最大长度积。

分析:k最大16,状压的重要标志

将子串中字母种类的状态压缩,先求该状态的最大子串长度再将该状态与该状态的子状态的最大子串长度取最大值

 

我们最后取长度积的时候肯定是让该状态与其补状态相乘,但是可能该状态的子状态的值更大一些,用这个子状态的值与其补状态相乘也是合法的(一个子串内的字母不与另一个子串内任何字母相同) 比如说dp[000111]=3,dp[000011]=4,dp[111000]=3

#include<cstdio>
#include<algorithm>
#include<cstring>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
const int N=2e3+5;
char s[N];
int dp[1<<16];
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
    	memset(dp,0,sizeof(dp));
    	int n,k;
    	scanf("%d%d",&n,&k);
    	scanf("%s",s);
    	for(int i=0;i<n;i++){ //n^2枚举所有子串状态 
    		int sta=0;
    		for(int j=i;j<n;j++){
    			sta|=(1<<(s[j]-'a'));
    			dp[sta]=max(dp[sta],j-i+1);//sta状态所能达到的最大长度 
			}
		}
		int up=1<<k;
		for(int i=0;i<up;i++){//求出字母种类小于等于当前状态所能达到的最大值
			for(int j=0;j<k;j++){
				if(i&(1<<j)){
					int sta=i^(1<<j);
					dp[i]=max(dp[i],dp[sta]); 
				}
			}
		} 
		int ans=0;
		for(int i=0;i<up;i++) ans=max(ans,dp[i]*dp[(up-1)^i]);
		printf("%lld\n",ans); 
	}
	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值