P1825 [USACO11OPEN]Corn Maze S

[USACO11OPEN]Corn Maze S

题面翻译

奶牛们去一个 N × M N\times M N×M 玉米迷宫, 2 ≤ N ≤ 300 , 2 ≤ M ≤ 300 2 \leq N \leq 300,2 \leq M \leq300 2N300,2M300

迷宫里有一些传送装置,可以将奶牛从一点到另一点进行瞬间转移。这些装置可以双向使用。

如果一头奶牛处在这个装置的起点或者终点,这头奶牛就必须使用这个装置。

玉米迷宫除了唯一的一个出口都被玉米包围。

迷宫中的每个元素都由以下项目中的一项组成:

  1. 玉米,# 表示,这些格子是不可以通过的。
  2. 草地,. 表示,可以简单的通过。
  3. 传送装置,每一对大写字母 A \tt{A} A Z \tt{Z} Z 表示。
  4. 出口,= 表示。
  5. 起点, @ 表示

奶牛能在一格草地上可能存在的四个相邻的格子移动,花费 1 1 1 个单位时间。从装置的一个结点到另一个结点不花时间。

题目描述

This past fall, Farmer John took the cows to visit a corn maze. But this wasn’t just any corn maze: it featured several gravity-powered teleporter slides, which cause cows to teleport instantly from one point in the maze to another. The slides work in both directions: a cow can slide from the slide’s start to the end instantly, or from the end to the start. If a cow steps on a space that hosts either end of a slide, she must use the slide.

The outside of the corn maze is entirely corn except for a single exit.

The maze can be represented by an N x M (2 <= N <= 300; 2 <= M <= 300) grid. Each grid element contains one of these items:

* Corn (corn grid elements are impassable)

* Grass (easy to pass through!)

* A slide endpoint (which will transport a cow to the other endpoint)

* The exit

A cow can only move from one space to the next if they are adjacent and neither contains corn. Each grassy space has four potential neighbors to which a cow can travel. It takes 1 unit of time to move from a grassy space to an adjacent space; it takes 0 units of time to move from one slide endpoint to the other.

Corn-filled spaces are denoted with an octothorpe (#). Grassy spaces are denoted with a period (.). Pairs of slide endpoints are denoted with the same uppercase letter (A-Z), and no two different slides have endpoints denoted with the same letter. The exit is denoted with the equals sign (=).

Bessie got lost. She knows where she is on the grid, and marked her current grassy space with the ‘at’ symbol (@). What is the minimum time she needs to move to the exit space?

输入格式

第一行:两个用空格隔开的整数 N N N M M M

2 ∼ N + 1 2\sim N+1 2N+1 行:第 i + 1 i+1 i+1 行描述了迷宫中的第 i i i 行的情况(共有 M M M个字符,每个字符中间没有空格)。

输出格式

一个整数,表示起点到出口所需的最短时间。

样例 #1

样例输入 #1

5 6
###=##
#.W.##
#.####
#.@W##
######

样例输出 #1

3

提示

例如以下矩阵, N = 5 , M = 6 N=5,M=6 N=5,M=6

###=##
#.W.##
#.####
#.@W##
######

唯一的一个装置的结点用大写字母 W \tt{W} W 表示。

最优方案为:先向右走到装置的结点,花费一个单位时间,再到装置的另一个结点上,花费 0 0 0 个单位时间,然后再向右走一个,再向上走一个,到达出口处,总共花费了 3 3 3 个单位时间。

解析

自信满满写一个dfs

#include<iostream>
#include<cstring>
using namespace std;
const int N=1002;
char c[N][N];
int n,m,fx[4][2]={{0,1},{1,0},{0,-1},{-1,0}},ans=1e9,a[N][N];
bool b[N][N]; 
void dfs(int x,int y,int t)
{
	if(c[x][y]=='=')
	{
		ans=min(ans,t);
		return;
	}
	if(t>=a[x][y]) return;
	a[x][y]=t;
	if(c[x][y]>='A'&&c[x][y]<='Z')
	 for(int i=0;i<n;i++)
	  for(int j=0;j<m;j++)
	   if(c[i][j]==c[x][y]&&i!=x&&j!=y)
	    dfs(i,j,t);
	int xx,yy;
	for(int i=0;i<4;i++)
	{
		xx=x+fx[i][0];
		yy=y+fx[i][1];
		if(xx<0||xx>n||yy<0||yy>m||c[xx][yy]=='#') 
		 continue;
		dfs(xx,yy,t+1);
	}
}
int main()
{
	memset(a,0x3f,sizeof(a));
	cin>>n>>m;
	for(int i=0;i<n;i++)
	 for(int j=0;j<m;j++)
	  cin>>c[i][j];
	for(int i=0;i<n;i++)
	 for(int j=0;j<m;j++)
	  if(c[i][j]=='@')
	  {
	  	dfs(i,j,0);
	  	cout<<ans<<endl;
	  	return 0;
	  }
} 

结果却被打脸了
在这里插入图片描述

再看数据规模,显然这道题的正解是双向BFS

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;

const int maxn = 1e3 + 10;
struct node{
	int x, y;
	int step;
	node() {
		step = 0;
	}
};
int dx[] = {0, 1, 0, -1};
int dy[] = {1, 0, -1, 0};
char a[maxn][maxn];
bool vis[maxn][maxn];
int n, m;

bool judge(int x, int y) {
	if(x < 1 || y < 1 || x > n || y > m)
		return true;
	if(vis[x][y] || a[x][y] == '#')
		return true;
	return false;
}

void find(int &x, int &y) {
	for(int i = 1; i <= n; i++) {
		for(int j = 1; j <= m; j++) {
			if(a[i][j] == a[x][y] && (i != x || j != y)) {
				x = i, y = j;
				return;
			}
		}
	}
}

void bfs() {
	node cur;
	for(int i = 1; i <= n; i++)
		for(int j = 1; j <= m; j++)
			if(a[i][j] == '@')
				cur.x = i, cur.y = j;
	queue<node>que;
	vis[cur.x][cur.y] = true;
	que.push(cur);
	while(!que.empty()) {
		cur = que.front();
		que.pop();
		if(a[cur.x][cur.y] == '=') {
			printf("%d", cur.step);
			return;
		}
		for(int i = 0; i < 4; i++) {
			int nx = cur.x + dx[i];
			int ny = cur.y + dy[i];
			if(judge(nx, ny))	continue;
			vis[nx][ny] = true;
			if(a[nx][ny] >= 'A' && a[nx][ny] <= 'Z') 
				vis[nx][ny] = false, find(nx, ny);
			node nex;
			nex.x = nx;
			nex.y = ny;
			nex.step = cur.step + 1;
			que.push(nex);
		}
	}
}

int main() {
	scanf("%d%d", &n, &m);
	for(int i = 1; i <= n; i++)
		scanf("%s", a[i] + 1);
	bfs();
	return 0;
} 


代码来源
在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值