Hrbust哈理工oj1013——Eqs

Description

Consider equations having the following form:
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

For each test case :

Line 1: Five coefficients a1, a2, a3, a4, a5, separated by blanks.

Process to the end of file.

Output

For each test case :

Line 1: A single integer that is the number of the solutions for the given equation.(The output will fit in 32 bit signed integers.)

Sample Input

37 29 41 43 47

Sample Output

654

 

此题如果遍历的话,时间复杂度将高达O(n^5),肯定会超时。

所以这道题的技巧是以提高空间复杂度为代价,减少时间复杂度。

具体为,把式子分成两部分,a1*x1^3 + a2*x2^3 和 a3*x3^3 + a4*x4^3 + a5*a5^5。

当前后两部分互为相反数时,即为一种解。

所以用一个数组用来存储前一部分得数的出现次数(例如:num[100] = 6 的意思就是前面部分所有情况中有6个情况等于100)

 

ac代码:

#include<cstdio>
#include<cstring>

using namespace std;
char num[37500050];
int main()
{
    int i, j, k;
    int a, b, c, d, e;
    while(scanf("%d%d%d%d%d", &a, &b, &c, &d, &e) != EOF)
    {
        memset(num, 0, sizeof(num));
        for(i = -50; i <= 50; i++)
        {
            if(i == 0)
                continue;
            for(j = -50; j <= 50; j++)
            {
                if(j == 0)
                    continue;
                int sum;
                sum = i*i*i*a + j*j*j*b;
                if(sum < 0)
                    sum += 37500050;
                num[sum]++;
            }
        }
        int ans = 0;
        for(i = -50; i <= 50; i++)
        {
            if(i == 0)
                continue;
            for(j = -50; j <= 50; j++)
            {
                if(j == 0)
                    continue;
                for(k = -50; k <= 50; k++)
                {
                    if(k == 0)
                        continue;
                    int sum;
                    sum = i*i*i*c + j*j*j*d + k*k*k*e;
                    sum = -sum;
                    if(sum < 0)
                        sum += 37500050;
                    ans += num[sum];
                }
            }
        }
        printf("%d\n", ans);
    }

    return 0;
}

如发现问题或者不足之处,欢迎在下方评论指出~

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值