PAT-1020-树的转化

1020 Tree Traversals
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

谷歌中文翻译:

假设二叉树中的所有键都是不同的正整数。 给定后序遍历序列和中序遍历序列,您应该输出相应二叉树的层级遍历序列。

输入规格:
每个输入文件包含一个测试用例。 对于每种情况,第一行给出一个正整数N(≤30),即二叉树中节点的总数。 第二行给出了后顺序,而第三行给出了顺序。 一行中的所有数字都用空格分隔。

输出规格:
对于每个测试用例,在一行中打印相应二叉树的级别顺序遍历序列。 一行中的所有数字必须完全由一个空格分隔,并且行尾不得有多余的空格。

思路:
数据结构的基本操作,知道先序中序后序层次的任意俩都能推出来。
对于二叉树基本操作不大懂的朋友可以看我这篇文章有另一种方法,算法笔记上的稍微麻烦点,看了柳神的还是照着柳神思路过了遍,非常奇妙的用这个index顺序检索。

#include<bits/stdc++.h>
using namespace std;
const int MAX_N = 510;
struct node {
	int index;
	int value;
};

int n;
vector<int> post, in; //后序 中序
vector<node> ans; 

bool cmp(node a, node b) {
	return a.index < b.index;
}

void pre(int root, int start, int end, int index) {
	if(start > end) 
		return ;
	int i = start;
	//遍历找到此时需要的结点 
	while(i < end && in[i] != post[root]) i++;
	ans.push_back({index, post[root]});
	//可以自行想象,一个子树根节点index
	//左子树为2*index+1,右子树为2*index+2 
	pre(root - 1 - end + i, start, i - 1, 2 * index + 1);
	pre(root - 1, i + 1, end, 2 * index + 2);
}

void init() {
	cin >> n;
	//vv.resize(int n,element)表示调整容器vector的大小为n,
	//扩容后的每个元素的值为element,默认为0
	//resize()会改变容器的容量和当前元素个数	
	post.resize(n);
	in.resize(n);
	for(int i = 0; i < n; i++) {
		cin >> post[i];
	}
	for(int j = 0; j < n; j++) {
		cin >> in[j];
	} 
}

int main() {
	init();
	//此时后序根节点是最后一个点
	//开始从中序的最开始开始遍历,最后一个点结束
	//根节点index置0 
	pre(n - 1, 0 , n - 1, 0);
	//存入是先序遍历
	//要是取出层序遍历,只要按index的顺序取出就行 
	sort(ans.begin(), ans.end(), cmp);
	for(int i = 0; i < ans.size(); i++) {
		if(i != 0) cout << " ";
		cout << ans[i].value;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值