PAT-1086-树的转化

1086 Tree Traversals Again
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
在这里插入图片描述
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

谷歌中文翻译:
可以以非递归方式使用堆栈来实现有序二叉树遍历。 例如,假设遍历6节点的二叉树(键的编号从1到6),则堆栈操作为:push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop()。 然后可以从此操作序列中生成唯一的二叉树(如图1所示)。 您的任务是给出此树的后置遍历序列。

输入规格:
每个输入文件包含一个测试用例。 对于每种情况,第一行都包含一个正整数N(≤30),它是树中节点的总数(因此,节点从1到N编号)。 然后紧接着2N行,每行以以下格式描述堆栈操作:“ Push X”,其中X是被压入堆栈的节点的索引; 或“ Pop”表示从堆栈中弹出一个节点。

输出规格:
对于每个测试用例,在一行中打印相应树的后遍历序列。 保证存在解决方案。 所有数字必须完全由一个空格分隔,并且行尾不得有多余的空格。

思路:
自己思考是建树结构里面存结点后序和值,但还是要像柳神大佬学习,比较基础的一个索引value搞定。
问题就是前序中序转后序。想一下stack的过程,先入后出,不就是左根右的中序么。而输入的时候是根左右的前序,存储一下就可以推出后序的结果。
这个输入需要手动去结束,在dev上运行需要ctrl + z来退出,不然就像我一直傻呆呆看着这程序咋不运行了内。

#include<bits/stdc++.h>
using namespace std;

int n;
stack<int> s;	//存放栈 
vector<int> pre, in, post, value;	//前、中、后序  存储索引对应的值

void init() {
	cin >> n;
	int key = 0;	//索引
	char str[5];	//因为push为4,pop为3 
	while(~scanf("%s", str)) {
		if(strlen(str) == 4) {
			//输入为pop的时候
			int num;
			cin >> num;
			value.push_back(num);
			pre.push_back(key);
			s.push(key++);
		} else {
			//输入为pop的时候
			in.push_back(s.top());
			s.pop(); 
		}
	} 
}

void postorder(int root, int start, int end) {
	if(start > end) 
		return ;
	int i = start;
	while(i < end && in[i] != pre[root]) i++;
	postorder(root + 1, start, i - 1);
	postorder(root + 1 + i - start, i + 1, end);
	post.push_back(pre[root]); 
} 

int main() {
	init();
	postorder(0, 0, n - 1);
	cout << value[post[0]];
	for(int i = 1 ; i < n; i++) {
		cout << " " << value[post[i]];
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值