私有vlan(PVLAN)实验配置步骤

拓扑图:
在这里插入图片描述
隔离VLAN(Isolated VLAN):同一个隔离VLAN 中的端口不能互相进行二层通信,一个私有VLAN 域中只有一个隔离VLAN。
群体VLAN(Community VLAN):同一个群体VLAN 中的端口可以互相进行二层通信,但不能与其它群体VLAN 中的端口进行二层通信。一个Private VLAN域中可以有多个群体VLAN。

注意:在配置PVLAN之前必须在全局模式下将VTP关闭或者将VTP模式更改为Transparent,这一步是必须的,否则不能配置PVLAN且会出现如下日志信息:
%Private VLANs can only be configured when VTP is in transparent/off modes in VTP version 1 or 2 and in server/transparent/off modes in VTP version 3 when pruning is turned off

关闭VTP:vtp mode off
更改为Transparent模式:vtp mode transparent

配置命令(基于全局配置模式):

SW1:
vlan 10
int vlan 10
ip add 192.168.10.254 255.255.255.0
no shu
int e0/0
sw mo ac
sw ac vlan 10
exit
ip dhcp pool vlan10
network 192.168.10.0 255.255.255.0
default-router 192.168.10.254

SW2:
vtp mode off		//关闭VTP
vlan 10
name primary_vlan
private-vlan primary	//定义主vlan
private-vlan association 20,30	//关联辅助vlan
vlan 20
name community_vlan
private-vlan community	//定义辅助vlan的community
vlan 30
name isolated_vlan
private-vlan isolated	//定义辅助vlan的isolated(隔离vlan)
exit
int range e0/0-1
switchport mode private-vlan host
switchport private-vlan host-association 10 20		//将接口划分进辅助vlan20
int e0/2
switchport mode private-vlan host
switchport private-vlan host-association 10 30		//将接口划分进辅助vlan30
interface Ethernet1/0
switchport mode private-vlan promiscuous	//更改该端口为混杂端口
switchport private-vlan mapping 10 20,30		//映射vlan
int e0/3
sw tr en do
sw mo tr

SW3:
vtp mode off	
vlan 10
name primary_vlan
private-vlan primary
private-vlan association 20,30
vlan 20
name community_vlan
private-vlan community
vlan 30
name isolated_vlan
private-vlan isolated
int e0/0
switchport mode private-vlan host
switchport private-vlan host-association 10 20
int e0/1
switchport mode private-vlan host
switchport private-vlan host-association 10 30
int e0/2
sw tr en do
sw mo tr

验证:
由于我们将SW1作为DHCPserver,现在来验证主机地址获取情况:
在这里插入图片描述验证可以看出,主机获取的地址主机位均和自己的编号一致:
VPC1的地址为:192.168.10.1
VPC2的地址为:192.168.10.2
VPC3的地址为:192.168.10.3
VPC4的地址为:192.168.10.4
VPC5的地址为:192.168.10.5

vlan及接口划分验证:
在这里插入图片描述VTP模式验证:
在这里插入图片描述
所有主机均能Ping通网关地

VPC1 ping VPC2:
由于VPC1、VPC2属于同一群体vlan(community vlan),因此是互通的

在这里插入图片描述
VPC4 ping VPC1:
在这里插入图片描述
VPC1 ping VPC3:
不同的群体vlan不能通信
在这里插入图片描述
VPC3 ping VPC5:
同一个隔离VLAN 中的端口不能互相进行二层通信
在这里插入图片描述

展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 游动-白 设计师: 上身试试
应支付0元
点击重新获取
扫码支付

支付成功即可阅读