B - Check-in question?

B - Check-in question?
Bob is a sorcerer. He lives in a cuboid room which has a length of A, a width of B and a height of C, so we represent it as ABC. One day, he finds that his room is filled with unknown dark energy. Bob wants to neutralize all the dark energy in his room with his light magic. He can summon a 112 cuboid at a time to neutralize dark energy. But the cuboid must be totally in dark energy to take effect. Can you foresee whether Bob can save his room or not?

输入
Input has T test cases. T≤100
For each line, there are three integers A, B, C.
1≤A,B,C≤100

输出
For each test case, if Bob can save his room, print “Yes”, otherwise print “No”.

样例输入
复制样例数据
1 1 2
1 1 4
1 1 1
样例输出
Yes
Yes
No
大意:
给你a * b * c大的立方体,问你能不能用1 * 1 * 2的立方体填满。
思路
显然,只要立方体任何一边为偶数,那么可以用1 * 1 * 2的立方体的边长为2的一边填偶数边,偶数边一定能填满,而剩下的两边由1 * 1 * 2的立方体的边长为1的一边填,一定能填满,只需a,b,c中又一边为偶数就能填满。
code:

#include<iostream>
using namespace std;
const int N = 1e5+10;


int main()
{
	int a,b,c;
	while(cin>>a>>b>>c)
	{
		if(!((a*b*c)%2))
			cout<<"Yes"<<endl;
		else 
			cout<<"No"<<endl;}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值