1014 Waiting in Line

题目描述

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customeri will take T​i minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1 is served at window​1 while customer​2 is served at window​2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.
At 08:01, customer1 is done and customer5 enters the line in front of window​1​ since that line seems shorter now. Customer2 will leave at 08:02, customer​4​​ at 08:06, customer3 at 08:07, and finally customer5​ at 08:10.

输入格式

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

输出格式

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

输入样例

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

输出样例

08:07
08:06
08:10
17:00
Sorry

题目大意

银行排列等候,规则如下:

  • 黄线前n条队,每条队m人,后来的在线外等候。
  • 顾客优先选择最短的队(即队首最早结束的)。若有多队长度相同,选择序号最小的。
  • 每个顾客处理事务的时间已给出,前n个顾客在8:00开始处理。17:00以后银行不开始处理事务(已经开始的不会强制结束)。

计算每个顾客所花的总时间(等待时间+处理时间)
(PS:真的很讨厌这种模拟的题目,稍有不慎就会偏离题意,或者少考虑某些情况。思路还是模仿别人的,有时间再重新整理吧。)

AC代码

#include <iostream>
#include <queue>
#include <cstdio>
using namespace std;

void printTime(int t){
	if(t == 10000)
		cout<<"Sorry"<<endl;
	else{
		int h = 8 + t / 60;
		int m = t % 60;
		printf("%02d:%02d\n", h, m);
	}
}

int main(){
	int n, m; //窗口数与队列容量
	int k, q; //顾客数与询问数
	int time[1010]; //顾客处理事务时间 
	int wait[30] = {0}; //队列当前已花时间(包括正在排队的) 
	int spend[1010]; //顾客所花总时间 
	queue<int> Qw[21]; //各窗口前队列每个人的服务时间 
	cin>>n>>m>>k>>q;
	for(int i = 1; i <= k; i++)
		cin>>time[i];
	for(int i = 1; i <= n * m; i++){ //先放满线内顾客 
		int p = (i - 1) % n + 1; //所进入的队列序号 
		Qw[p].push(time[i]);
		if(wait[p] >= 540) //已经等到了五点
			spend[i] = 10000;
		else{ //时间来得及 
			spend[i] = time[i] + wait[p];
			wait[p] = spend[i];	
		}	
	}
	for(int i = n * m + 1; i <= k; i++){ //放线外的 
		int min = 10000, minp;
		//找到最先有人办完业务的队 
		for(int j = 1;j <= n; j++){
			if(Qw[j].front() < min){
				min = Qw[j].front();
				minp = j;
			}
		//	cout<<Qw[j].front()<<endl;
		}
		if(wait[minp] >= 540) //超时 
			spend[i] = 10000;
		else{
			Qw[minp].push(time[i]); //加入队列
			for(int j = 1; j <= n; j++){ //其余队伍的剩余时间需更新 
				if(j != minp)
					Qw[j].front() -= Qw[minp].front();
			}
			Qw[minp].pop(); //前一人出队
			spend[i] = time[i] + wait[minp];
			wait[minp] = spend[i];
		} 
	}
	for(int i = 0; i < q; i++){
		int id;
		cin>>id;
		printTime(spend[id]);
	} 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值