1023 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题目大意及思路

判断一个数的2倍是否为该数的重新排列组合。
将该数a及该数的两倍b用数组存储,设置一个hash数组(我这里用的是map)存储该数所有位中0-9的个数。若a、b对应的hash数组相减为全零,则符合题意。

AC代码

#include <iostream>
#include <map>
#include <cstring>
using namespace std;

int main(){
	char num[20];
	int num2[21] = {0};
	cin>>num;
	map<int, int> mp;
	int last = 0; //前一位进位
	int k; //当前位 
	int j = 0;
	for(int i = strlen(num) - 1; i >= 0; i--){
		int temp = num[i] - '0';
		mp[temp]++;
		k = (temp * 2 + last) % 10;
		last = (temp * 2 + last) /10;
		mp[k]--;
		num2[j++] = k;
	} 
	if(last) //第一位进位
		num2[j++] = last;	
	int i;
	for(i = 0; i < 10; i++)
		if(mp[i] != 0)
			break;
	if(i != 10) cout<<"No"<<endl;
	else cout<<"Yes"<<endl;
	while(num2[j] == 0)
		j--; //找到第一个不为0的位
	for(; j >= 0; j--)
		cout<<num2[j]; 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值