1089 Insert or Merge

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

AC代码

#include <cstdio>
#include <iostream>
#include <algorithm> 
using namespace std; 

int main(){ 		
	int n, A[101], B[101];
	cin>>n;
	for(int i = 0; i < n; i++)
		cin>>A[i];
	for(int i = 0; i < n; i++)
		cin>>B[i];
	int k = 1; //找到第一个无序的位置
	while(k < n && B[k] >= B[k - 1]) 
		k++;
	int i = k;
	while(i < n && A[i] == B[i])
		i++;
	if(i == n){
		cout<<"Insertion Sort"<<endl;
		sort(A, A + k + 1);
	} 
	else{
		cout<<"Merge Sort"<<endl;
		int len = 1; //步长
		bool flag = false; //标记是否迭代到中间序列
		while(flag == false){
			for(i = 0; i < n; i++)
				if(A[i] != B[i]) break;
			if(i == n) flag = true;
			len *= 2;
			for(i = 0; i < n / len; i++)
				sort(A + i * len, A + (i + 1) * len);
			sort(A + (n / len) * len, A + n);
		} 
	}
	for(int i = 0; i < n; i++){
		if(i != 0) cout<<" ";
		cout<<A[i];
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
在 MyBatis 中,可以使用 `<insert>` 标签来处理插入操作,使用 `<update>` 标签来处理更新操作。但是,如果你想实现一个插入或更新操作,你需要写两个不同的 SQL 语句,这很麻烦。幸运的是,Oracle 提供了一个 MERGE 语句,可以同时实现插入和更新操作。 下面是一个基本的 Oracle MERGE 语句示例: ```sql MERGE INTO table_name t USING (SELECT ? col1, ? col2, ? col3 FROM dual) s ON (t.key_column = ?) WHEN MATCHED THEN UPDATE SET t.col1 = s.col1, t.col2 = s.col2, t.col3 = s.col3 WHEN NOT MATCHED THEN INSERT (t.key_column, t.col1, t.col2, t.col3) VALUES (?, ?, ?, ?) ``` 其中,`table_name` 是要插入或更新的表名;`key_column` 是用于匹配的列名;`col1`、`col2`、`col3` 是要插入或更新的列名;`?` 是占位符,用于传递参数。 在 MyBatis 中,你可以使用 `<update>` 和 `<insert>` 标签来执行这个 MERGE 语句。下面是一个示例: ```xml <update id="insertOrUpdate" parameterType="com.example.entity.MyEntity"> MERGE INTO my_table t USING (SELECT #{col1} col1, #{col2} col2, #{col3} col3 FROM dual) s ON (t.id = #{id}) WHEN MATCHED THEN UPDATE SET t.col1 = s.col1, t.col2 = s.col2, t.col3 = s.col3 WHEN NOT MATCHED THEN INSERT (t.id, t.col1, t.col2, t.col3) VALUES (#{id}, #{col1}, #{col2}, #{col3}) </update> ``` 在这个示例中,`MyEntity` 是一个 Java 实体类,包含 `id`、`col1`、`col2`、`col3` 四个属性。`parameterType` 属性指定了传递给 SQL 语句的参数类型。在 SQL 语句中,使用 `#{}` 占位符来引用 Java 实体类中的属性。 当你调用这个 SQL 语句时,如果 `id` 已经存在于表中,则会更新 `col1`、`col2`、`col3` 列的值;否则,会插入新的一行,其中包括 `id`、`col1`、`col2`、`col3` 列的值。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值