1091 Acute Stroke(BFS)

这篇博客介绍了如何使用BFS算法计算急性脑卒中核心区域的体积。给定MRI切片中核心区域的标识,通过计算所有满足体积阈值的连通核心区域的像素数来确定总体积。题目提供了输入输出规格、样例输入和输出,并讨论了使用DFS和BFS算法的优劣,最后给出了通过所有测试点的BFS代码实现。
摘要由CSDN通过智能技术生成

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M×N matrix, and the maximum resolution is 1286 by 128); L (≤60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M×N matrix of 0’s and 1’s, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1’s to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are connected and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.

figstroke.jpg

Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:

3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0

Sample Output:

26

题目大意

给定大小的M * N * L三维矩阵中,一部分是正常区域(0表示),一部分是脑卒中区域(1表示),找出那些连通的脑卒中区域,且只有像素数量大于等于给定阈值T的区域才进行累加计算。

思路

理论上讲,本题可用BFS、DFS两种方法,只需对每个值为1的像素进行访问,访问后将值置为0即可(注意搜索时不要越界)。以下为DFS代码:

#include <cstdio>
#include <iostream>
#include <vector> 
using namespace std; 

int dx[6] = {1, 0, -1, 0, 0, 0}, dy[6] = {0, 1, 0, -1, 0, 0};
int dz[6] = {0, 0, 0, 0, 1, -1};
int a[1286][128][60];
int M, N, L, T, v = 0, vol = 0;

bool judge(int i, int j, int k){ //判断是否越界
	return i >= 0 && i < M && j >= 0 && j < N && k >= 0 && k < L;
}

void DFS(int x, int y, int z){
	if(judge(x, y, z) && a[x][y][z] == 1){
		v++;
		a[x][y][z] = 0;
		for(int i = 0; i < 6; i++)
			DFS(x + dx[i], y + dy[i], z + dz[i]);		
	}		
}

int main(){ 		
	cin>>M>>N>>L>>T;
	for(int k = 0; k < L; k++)
		for(int i = 0; i < M; i++)
			for(int j = 0; j < N; j++)
				cin>>a[i][j][k];
	for(int k = 0; k < L; k++)
		for(int i = 0; i < M; i++)
			for(int j = 0; j < N; j++){
				if(a[i][j][k] == 1){
					v = 0;
					DFS(i, j, k);
					if(v >= T) vol += v;
				}
			}
	cout<<vol;
	return 0;
}

DFS的代码更简洁,所以我的首选是它,然而,由于递归层数较多,有两个测试点段错误。这也是DFS的缺点。因此最终还是要用BFS,思路类似。

AC代码

#include <cstdio>
#include <iostream>
#include <queue> 
using namespace std; 

struct node{
	int x, y, z;
	node(int _x, int _y, int _z):x(_x), y(_y), z(_z){}
};
int dx[6] = {1, 0, -1, 0, 0, 0}, dy[6] = {0, 1, 0, -1, 0, 0};
int dz[6] = {0, 0, 0, 0, 1, -1};
int a[1286][128][60];
int M, N, L, T, vol = 0;

bool judge(int i, int j, int k){ //判断是否越界
	return i >= 0 && i < M && j >= 0 && j < N && k >= 0 && k < L;
}

void BFS(int x, int y, int z){
	int v = 1; //该区域体积 
	a[x][y][z] = 0;
	queue<node> Q;
	Q.push(node(x, y, z));
	while(!Q.empty()){
		node top = Q.front();
		Q.pop();
		for(int i = 0; i < 6; i++){
			int newX = top.x + dx[i];
			int newY = top.y + dy[i];
			int newZ = top.z + dz[i];
			if(judge(newX, newY, newZ) && a[newX][newY][newZ] == 1){
				a[newX][newY][newZ] = 0;
				v++;
				Q.push(node(newX, newY, newZ));
			}
		}
	}
	if(v >= T) vol += v;
}

int main(){ 		
	cin>>M>>N>>L>>T;
	for(int k = 0; k < L; k++)
		for(int i = 0; i < M; i++)
			for(int j = 0; j < N; j++)
				cin>>a[i][j][k];
	for(int k = 0; k < L; k++)
		for(int i = 0; i < M; i++)
			for(int j = 0; j < N; j++){
				if(a[i][j][k] == 1)
					BFS(i, j, k);
			}
	cout<<vol;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Acute3D Viewer是一款用于查看Acute3D软件生成的三维模型的软件。以下是Acute3D Viewer的安装教程。 第一步,打开Acute3D Viewer的安装文件,双击运行该文件。 第二步,选择您要将Acute3D Viewer安装到的目标文件夹。您可以选择默认目标文件夹,也可以自定义目标文件夹。点击“下一步”继续。 第三步,选择开始菜单文件夹。您可以选择将Acute3D Viewer的快捷方式添加到开始菜单的默认文件夹,也可以选择创建一个新的文件夹。点击“下一步”继续。 第四步,选择额外任务。您可以选择添加Acute3D Viewer的桌面快捷方式和快速启动图标。点击“下一步”继续。 第五步,选择安装类型。您可以选择完全安装或者自定义安装。如果您对安装过程不了解,建议选择默认安装。点击“下一步”继续。 第六步,点击“安装”按钮开始安装Acute3D Viewer。安装过程可能需要一些时间,请耐心等待。 第七步,等待安装完成。安装完成后,您可以选择打开Acute3D Viewer。 第八步,启动Acute3D Viewer。在启动Acute3D Viewer之前,系统可能会提示您选择连接Acute3D Viewer的3D模型文件的默认应用程序。您可以选择Acute3D Viewer作为默认应用程序,然后单击“确定”。 这样,您就成功地安装了Acute3D Viewer。现在,您可以使用Acute3D Viewer来查看和浏览Acute3D软件生成的三维模型了。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值