1110 Complete Binary Tree

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

题目大意及思路

判断一棵二叉树是否为完全二叉树,若是,则输出其最后一个结点的索引,若不是,则输出其根结点索引。
根据完全二叉树的特征,其空结点只能在最后,中间不能有空结点(设为-1)。于是通过层序遍历,当遍历到第一个空结点时退出,再依次遍历队列中剩余结点,若存在非空结点,则不为完全二叉树。
一个需要注意的点是,这里的N可能为两位数,所以在输入时左右结点需用string存储(我用char存储时三个测试点出错),stoi()函数将其转化为int。

AC代码

#include <string>
#include <queue>
#include <iostream>
using namespace std;

struct node{
	int lc = -1, rc = -1;
}BTree[21];

int main(){
	int n, root;
	int hashTable[21] = {0};
	cin>>n;
	string l, r;
	for(int i = 0; i < n; i++){
		cin>>l>>r;
		if(l != "-"){
			BTree[i].lc = stoi(l);
			hashTable[BTree[i].lc] = 1;
		}
		if(r != "-"){
			BTree[i].rc = stoi(r);	
			hashTable[BTree[i].rc] = 1;
		} 
	}
	for(int i = 0; i < n; i++)
		if(hashTable[i] == 0){
			root = i;break;
		}
	int last = root;
	queue<int> Q;
	Q.push(root);
	int top;
	while(true){ //找到第一个空结点 
		top = Q.front();
		Q.pop();
		if(top == -1) break;
		last = top;
		Q.push(BTree[top].lc);
		Q.push(BTree[top].rc);	
	}
	while(!Q.empty()){
		top = Q.front();
		Q.pop();
		if(top != -1){
			cout<<"NO "<<root;
			return 0;
		}
	}
	cout<<"YES "<<last;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值