质因子分解之——1059 Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

 解题思路:

1.输入N

int n;
scanf("%d",&n);

2.构造一个结构体数组来存储不同的质因子以及质因子个数。考虑到2*3*5*7*9*11*13*17*19*23*29已经超过int范围,数组开到10就可以了。

srtruct fator{
   int x,cnt;//x为质因子,cnt为其个数
}fac[10];

3.质因子要么全小于等于sqrt(n),要么只有一个质因子大于sqrt(n)。

     先判断<=sqrt(n)的质因子

num=0;
for(int i=2;i<=sqrt(n);i++){
     if(n%i==0){//i是质因子
        fac[nun].x=i;
        fac[num].cnt=0;
        while(n%i==0){
           fac[num].cnt++
           n/=i;
        }
      num++;
}

n除掉所有的<=sqrt(n)的质因子后;若==1,则所有质因子已经求出了,否则还有一个大于sqrt(n)的质因子

if(n!=1){
    fac[num].x=n;
    fac[num].cnt=1;
    num++;
}

4.输出

特殊情况:n==1,注意n=要先输,因为有质因子时后面会改变n的大小

printf("%d=",n);
if(n==1)
  {printf("1");return 0;}

其他情况,注意质因子个数为1时不要输x^cnt的形式

for(int i=0;i<num;i++){
   printf("%d",fac[i].x);
   if(fac[i].cnt>1)printf("^%d",fac[i].cnt);
   if(i!=num-1)printf("*");
}

解题答案

#include <cstdio>
#include <cmath>
 struct factor{
 	int x,cnt;
 }fac[10];
 int main(){
 	int n,num=0;
 	scanf("%d",&n);
 	printf("%d=",n);
    if(n==1)
      {printf("1");return 0;}
 	for(int i=2;i<=(int)sqrt(n);i++){
 		if(n%i==0){
 			fac[num].x=i;
 			fac[num].cnt=0;
 			while(n%i==0){
 				fac[num].cnt++;
 				n/=i;
 			}
 			num++;
 		}
 	}
 	if(n!=1){
 		fac[num].x=n;
 		fac[num].cnt=1;
 		num++;
 	}
 	for(int i=0;i<num;i++){
 		printf("%d",fac[i].x);
 		if(fac[i].cnt>1)printf("^%d",fac[i].cnt);
 		if(i!=num-1)printf("*");
 	}
 	return 0;
 }

sqrt是math.h的函数,返回值是double型

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值