1039 Course List for Student (25 分)

1039 Course List for Student (25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N**i (≤200) are given in a line. Then in the next line, N**i student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

分析:

这道题由于学生姓名由字母给出以及考生数和课程数乘积过大,因而使用字符串hash和使用vector数组来进行处理。getID函数相当于把题目中给的每个学生的编号string映射成了唯一的整数,我们可以使用相当于26进制转10进制的方法来处理前三个字母的映射,最后再在末尾加上剩余的数字,同时selectCourse这个vector相当于把每个学生的id来作为索引项,然后依次加入每个课程,最后在输入每个学生字符串时,将vector中的课程进行从小到大的排序后输出。

代码:

#include<bits/stdc++.h>
using namespace std;
const int n=40010;
const int m=26*26*26*10+1;//姓名组成的散列上限
vector <int> selectCourse[m];//每个学生选择的课程编号 

int getID(string name){
	int id=0;
	for(int i=0;i<3;i++){//前三个字母26进制转10进制 
		id=id*26+(name[i]-'A');
	}
	id=id*10+name[3]-'0';//末尾的数字 
    return id; 
	
}
int main(){
	
	//ifstream cin("1.txt");
	
	string name;
	int n,k;
	cin>>n>>k;
	for(int i=0;i<k;i++){
		int course,x;//课程编号以及选课人数
		cin>>course>>x;
		for(int j=0;j<x;j++){
			cin>>name;
			int id=getID(name);
			selectCourse[id].push_back(course);//将姓名散列作为一个整数编号 
		} 
		
	}
	for(int i=0;i<n;i++){
		cin>>name;
		int id=getID(name);
		sort(selectCourse[id].begin(),selectCourse[id].end());
		cout<<name<<" "<<selectCourse[id].size();
		for(int j=0;j<selectCourse[id].size();j++){
			cout<<" "<<selectCourse[id][j];
		} 
		cout<<endl;
		
	} 
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值