1095. Cars on Campus (30)-PAT甲级真题(map,排序)

Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each “in” record is paired with the chronologically next record for the same car provided it is an “out” record. Any “in” records that are not paired with an “out” record are ignored, as are “out” records not paired with an “in” record. It is guaranteed that at least one car is well paired in the input, and no car is both “in” and “out” at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

题目大意:给出n个车牌号、时间点、进出状态的记录,然后查询k个时间点这时校园内的车辆个数。最后还要输出在校园里面呆的时间最长的车的车牌号,以及呆了多久的时间。如果有多辆车就按照它的字母从小到大输出车牌。
配对要求是,如果一个车多次进入未出,取最后一个值;如果一个车多次out未进入,取第一个值
注意:一个车可能出入校园好多次,停车的时间应该取之和
#include <iostream>
#include <string>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;

struct Cars{
    string plate_num; //车牌号
    int time;
    bool flag; //flag 为true 代表 in, false 代表 out
}car[10005]; //所有记录
vector<Cars> v; //有效记录

map<string, int> parkTime; //车牌号->总停留时长

int timeToint(int hh, int mm, int ss){ //转换成以s为单位 比 直接去计算比较 时分秒好太多了
    return hh * 3600 + mm * 60 + ss;
}

bool cmp(Cars a, Cars b){
    if(a.plate_num != b.plate_num) return a.plate_num < b.plate_num;
    else return a.time < b.time;
}
bool cmp1(Cars a, Cars b){
    return a.time < b.time;
}
int main(){
    int n, k, hh, mm, ss;
    scanf("%d%d",&n, &k);
    
    string status;
    for(int i=0; i<n; i++){
        car[i].plate_num.resize(10); //虽然string可以用 scanf读入,但是最好还是cin吧,因为会有出现未知的错误导致不能读入 
        scanf("%s %d:%d:%d", &car[i].plate_num[0], &hh, &mm, &ss);
        cin >> status;
        car[i].time = timeToint(hh, mm, ss); //转化为以s为时间单位 可以简化很多操作。
        if(status == "in"){
            car[i].flag = true;
        }else{
            car[i].flag = false;
        }
    }
    
    sort(car, car + n, cmp); //按照车牌号 从小到大排序 
    /*
        找到有效记录,同时计算每辆车的总时长
    */
    int maxTime = -1; //最长总停留时间
    for(int i=0; i<n-1; i++){
        if(car[i].plate_num == car[i + 1].plate_num && car[i].flag == true && car[i + 1].flag == false){ //i和i+1是同一辆车,且in,out匹配
            v.push_back(car[i]);
            v.push_back(car[i + 1]);
            int inTime = car[i + 1].time - car[i].time; //此次停留时间
            if(parkTime.count(car[i].plate_num) == 0){ //如果map中还没有这辆车,置为0
                parkTime[car[i].plate_num] = 0; //这个初始化其实不写也可以,因为默认的就是0
            }
            parkTime[car[i].plate_num] += inTime; //累加此车的 停车时长
            maxTime = max(maxTime, parkTime[car[i].plate_num]); //找到停车总时长中最大的
        }
    } 
    
    sort(v.begin(), v.end(), cmp1); //按照时间从小到大排序 有效记录
    
     /*
        给出k个查询,找出每个查询的时间点 在这个时间点之前包括这个时间点内 校内当前停了多少辆车 
         now指向不超过当前查询时间的记录,numCar为当前校园内车辆数
         v中 按时间顺序保存着 车辆有效记录
    */
    
    int now = 0, numCar = 0;
	for(int i=0; i<k; i++){
        scanf("%d:%d:%d", &hh, &mm, &ss); //注:查询的时间是升序的 因此now无需每次都指向第一条记录,而是一直往下走就行
        int time = timeToint(hh, mm, ss); //把查询时间 也转换成 以s为单位
        while(now < v.size() && v[now].time <= time){
            if(v[now].flag == true) numCar++; //进来一辆 加一辆 
            else numCar--; // 出去一辆 减一辆
            now++; //指向下一条记录
        }
        printf("%d\n", numCar);
    }
    
    //map中存放着各个 车辆停留的总时长 找到最长时间就可以了
    for(map<string, int>::iterator it = parkTime.begin(); it != parkTime.end(); it++){
        if(it -> second == maxTime){
            printf("%s ", it -> first.c_str());
        }
    }
    
    printf("%02d:%02d:%02d", maxTime / 3600, maxTime % 3600 / 60, maxTime % 60); //转换成时分秒
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值