1050 String Subtraction (20 分)

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题目大意:给出两个字符串,在第一个字符串中删除第二个字符串中出现过的所有字符并输出

暴力解法

#include <iostream>
using namespace std;
#include <string>

int main(){
    string s1, s2;
    getline(cin, s1); //getline读取一行 以换行结束
    getline(cin, s2);
    
    bool flag; //用来标记 当前s1字符 是否 在 s2中出现过
    for(int i=0; i<s1.size(); i++){
        flag = false;
        for(int j=0; j<s2.size(); j++){
            if(s1[i] == s2[j]){
                flag = true;
            }
        }
        if(!flag){ //若s2中 没有 s1这个字符 直接输出
            cout << s1[i];
        }
    }
    return 0;
}

哈希解法

#include <iostream>
using namespace std;
#include <string>
#include <map>

int main(){
    string s1, s2;
    getline(cin, s1); //getline读取一行 以换行结束
    getline(cin, s2);
    
    map<char, bool> mp; //记录字符是否在 第二个字符串中出现过 默认为false 如果出现过置为 true
    for(int i=0; i<s2.size(); i++){
        char c = s2[i];
        mp[c] = true;
    }
    
    for(int i=0; i<s1.size(); i++){ //如果在第二个字符串中未出现过 直接输出该字符
        char c = s1[i];
        if(mp[c] == false){
            cout << c;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值