mpls vxn基础配置与解析

实验目的​​​​​​​ 

1、熟悉MPLS VXN 双标签工作机制。

2、熟悉MPLS VXN VRF RD RT的作用含义。

3、熟练的掌握MPLS VXN 的配置和校验。

实验拓扑

接口ip配置:

R1(config)#interface e0/0                                                                                                                      
R1(config-if)#ip address 192.168.1.1 255.255.255.0                                                                                             
R1(config-if)#no shutdown                                                                                                                      
R1(config)#interface loopback 0                                                                                                                
R1(config-if)#interface loopback 1                                                                                                             
R1(config-if)#ip address 11.11.11.11 255.255.255.0 

R2(config)#interface e0/0                                                                                                                      
R2(config-if)#ip address 192.168.2.2 255.255.255.0                                                                                             
R2(config-if)#no shutdown                                                                                                                      
R2(config)#interface loopback 0                                                                                                                
R2(config-if)#ip address 10.1.1.2 255.255.255.0                                                                                                
R2(config-if)#interface loopback 1                                                                                                             
R2(config-if)#ip address 22.22.22.22 255.255.255.0 

R3(config)#interface e0/0                                                                                                                      
R3(config-if)#no shutdown                                                                                                                      
R3(config-if)#interface e0/0.10                                                                                                                
R3(config-subif)#encapsulation dot1Q 10                                                                                                        
R3(config-subif)#ip address 192.168.1.3 255.255.255.0                                                                                          
R3(config-subif)#interface e0/0.20                                                                                                             
R3(config-subif)#encapsulation dot1Q 20                                                                                                        
R3(config-subif)#ip address 192.168.2.3 255.255.255.0 
R3(config)#interface e0/1                                                                                                                      
R3(config-if)#ip address 34.34.34.3 255.255.255.0                                                                                              
R3(config-if)#no shutdown  
R3(config)#interface loopback 0                                                                                                                                                                                                                                       
R3(config-if)#ip address 3.3.3.3 255.255.255.0  

R4(config)#interface e0/1                                                                                                                      
R4(config-if)#ip address 34.34.34.4 255.255.255.0                                                                                              
R4(config-if)#no shutdown                                                                                                                      
R4(config-if)#interface e0/0                                                                                                                   
R4(config-if)#ip address 45.45.45.4 255.255.255.0                                                                                              
R4(config-if)#no shutdown 
R4(config)#interface loopback 0                                                                                                                                                                                                                                       
R4(config-if)#ip address 4.4.4.4 255.255.255.0  

R5(config)#interface e0/0                                                                                                                      
R5(config-if)#ip address 45.45.45.5 255.255.255.0                                                                                              
R5(config-if)#no shutdown                                                                                                                      
R5(config-if)#interface e0/1                                                                                                                   
R5(config-if)#ip address 56.56.56.5 255.255.255.0                                                                                              
R5(config-if)#no shutdown
R5(config)#interface loopback 0                                                                                                                                                                                                                                       
R5(config-if)#ip address 5.5.5.5 255.255.255.0   

R6(config)#interface e0/1                                                                                                                      
R6(config-if)#ip address 56.56.56.6 255.255.255.0                                                                                              
R6(config-if)#no shutdown                                                                                                                      
R6(config-if)#interface e0/0                                                                                                                   
R6(config-if)#no shutdown                                                                                                                      
R6(config-if)#interface e0/0.70                                                                                                                
R6(config-subif)#encapsulation dot1Q 70                                                                                                        
R6(config-subif)#ip add                                                                                                                        
R6(config-subif)#ip address 192.168.7.6 255.255.255.0                                                                                          
R6(config-subif)#interface e0/0.80                                                                                                             
R6(config-subif)#encapsulation dot1Q 80                                                                                                        
R6(config-subif)#ip add                                                                                                                        
R6(config-subif)#ip address 192.168.8.6 255.255.255.0
R6(config)#interface loopback 0                                                                                                                                                                                                                                       
R6(config-if)#ip address 6.6.6.6 255.255.255.0   

R7(config)#interface e0/0                                                                                                                      
R7(config-if)#ip address 192.168.7.7 255.255.255.0                                                                                             
R7(config-if)#no shutdown                                                                                                                      
R7(config)#interface loopback 0                                                                                                                
R7(config-if)#ip address 10.2.2.2 255.255.255.0                                                                                                
R7(config-if)#interface loopback 1                                                                                                             
R7(config-if)#ip address 77.77.77.77 255.255.255.0 

R8(config)#interface e0/0                                                                                                                      
R8(config-if)#ip address 192.168.8.8 255.255.255.0                                                                                             
R8(config-if)#no shutdown                                                                                                                      
R8(config)#interface loopback 0                                                                                                                
R8(config-if)#ip  address 10.2.2.2 255.255.255.0                                                                                               
R8(config-if)#interface loopback 1                                                                                                             
R8(config-if)#ip  address 88.88.88.88 255.255.255.0  

SW1(config)#vlan 10                                                                                                                            
SW1(config-vlan)#vlan 20                                                                                                                       
SW1(config)#interface e0/1                                                                                                                     
SW1(config-if)#switchport trunk encapsulation dot1q                                                                                            
SW1(config-if)#switchport mode trunk  
SW1(config-if)#switchport trunk allowed vlan 10,20 
SW1(config)#interface e0/0                                                                                                                     
SW1(config-if)#switchport mode access                                                                                                          
SW1(config-if)#switchport access vlan 10                                                                                                       
SW1(config-if)#interface e0/2                                                                                                                  
SW1(config-if)#switchport mode access                                                                                                          
SW1(config-if)#switchport access vlan 20  

SW2(config)#interface e0/0                                                                                                                     
SW2(config-if)#switchport mode access                                                                                                          
SW2(config-if)#switchport access vlan 70                                                                                                       
SW2(config-if)#interface e0/1                                                                                                                  
SW2(config-if)#switchport trunk encapsulation dot1q                                                                                            
SW2(config-if)#switchport mode trunk                                                                                                           
SW2(config-if)#switchport trunk allowed vlan 70,80                                                                                             
SW2(config-if)#interface e0/2                                                                                                                  
SW2(config-if)#switchport mode access                                                                                                          
SW2(config-if)#switchport access vlan 80 

完成R3 R4 R5 R6的底层协议和MPLS。

R3(config)#router ospf 1                                                                                                                       
R3(config-router)#router-id 3.3.3.3                                                                                                            
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0                                                                                               
R3(config-router)#network 34.34.34.3 0.0.0.0 area 0                                                                                            
R3(config)#mpls label protocol ldp                                                                                                             
R3(config)#mpls label range 300 399                                                                                                            
R3(config)#mpls ldp router-id loopback 0                                                                                                       
R3(config)#interface e0/1                                                                                                                      
R3(config-if)#mpls ip

R4(config)#router ospf 1                                                                                                                       
R4(config-router)#router-id 4.4.4.4                                                                                                            
R4(config-router)#network 4.4.4.4 0.0.0.0 area 0                                                                                               
R4(config-router)#network 34.34.34.4 0.0.0.0 area 0                                                                                            
R4(config-router)#network 45.45.45.4 0.0.0.0 area 0                                                                                            
R4(config)#mpls label protocol ldp                                                                                                             
R4(config)#mpls label range 400 499                                                                                                            
R4(config)#mpls ldp router-id loopback 0                                                                                                       
R4(config)#interface range e0/0-1                                                                                                              
R4(config-if-range)#mpls ip 

R5(config)#router ospf 1                                                                                                                       
R5(config-router)#network 5.5.5.5 0.0.0.0 area 0                                                                                               
R5(config-router)#network 45.45.45.5 0.0.0.0 area 0                                                                                            
R5(config-router)#network 56.56.56.5 0.0.0.0 area 0                                                                                            
R5(config)#mpls label protocol ldp                                                                                                             
R5(config)#mpls label range 500 599                                                                                                            
R5(config)#mpls ldp router-id loopback 0                                                                                                       
R5(config)#interface range e0/0-1                                                                                                              
R5(config-if-range)#mpls ip  

R6(config)#router ospf 1                                                                                                                       
R6(config-router)#router-id 6.6.6.6                                                                                                            
R6(config-router)#network 6.6.6.6 0.0.0.0 area 0                                                                                               
R6(config-router)#network 56.56.56.6 0.0.0.0 area 0                                                                                            
R6(config)#mpls label protocol ldp                                                                                                             
R6(config)#mpls label range 600 699                                                                                                            
R6(config)#mpls ldp router-id loopback 0                                                                                                       
R6(config)#interface e0/1                                                                                                                      
R6(config-if)#mpls ip 

确保R3 R4 R5 R6 loopback 0接口可以相互PING通。

R3#ping 6.6.6.6 source 3.3.3.3                                                                                                                 
Type escape sequence to abort.                                                                                                                 
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:                                                                               
Packet sent with a source address of 3.3.3.3                                                                                                   
!!!!!                                                                                                                                          
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms 

确认MPLS LDP 邻接关系建立

R4#show mpls ldp neighbor                                                                                                                      
    Peer LDP Ident: 3.3.3.3:0; Local LDP Ident 4.4.4.4:0                                                                                       
        TCP connection: 3.3.3.3.646 - 4.4.4.4.60549                                                                                            
        State: Oper; Msgs sent/rcvd: 12/14; Downstream                                                                                         
        Up time: 00:01:55                                                                                                                      
        LDP discovery sources:                                                                                                                 
          Ethernet0/1, Src IP addr: 34.34.34.3                                                                                                 
        Addresses bound to peer LDP Ident:                                                                                                     
          192.168.1.3     192.168.2.3     34.34.34.3      3.3.3.3                                                                              
    Peer LDP Ident: 5.5.5.5:0; Local LDP Ident 4.4.4.4:0                                                                                       
        TCP connection: 5.5.5.5.13638 - 4.4.4.4.646                                                                                            
        State: Oper; Msgs sent/rcvd: 11/11; Downstream                                                                                         
        Up time: 00:01:04                                                                                                                      
        LDP discovery sources:                                                                                                                 
          Ethernet0/0, Src IP addr: 45.45.45.5                                                                                                 
        Addresses bound to peer LDP Ident:                                                                                                     
          45.45.45.5      56.56.56.5      5.5.5.5 

如上现象表明LDP 邻居关系建立。

接着我们查看下R3 R6 之间LSP的标签关联信息。

R3#show mpls forwarding-table                                                                                                                  
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop                                                                       
Label      Label      or Tunnel Id     Switched      interface                                                                                 
300        No Label   4.4.4.4/32       0             Et0/1      34.34.34.4                                                                     
301        Pop Label  45.45.45.0/24    0             Et0/1      34.34.34.4                                                                     
302        401        5.5.5.5/32       0             Et0/1      34.34.34.4                                                                     
303        402        56.56.56.0/24    0             Et0/1      34.34.34.4                                                                     
304        403        6.6.6.6/32       0             Et0/1      34.34.34.4  
//如上表明R3 抵达6.6.6.0/24 本地标签304 远端标签403

R4#show mpls forwarding-table                                                                                                                  
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop                                                                       
Label      Label      or Tunnel Id     Switched      interface                                                                                 
400        No Label   3.3.3.3/32       570           Et0/1      34.34.34.3                                                                     
401        No Label   5.5.5.5/32       0             Et0/0      45.45.45.5                                                                     
402        Pop Label  56.56.56.0/24    0             Et0/0      45.45.45.5                                                                     
403        503        6.6.6.6/32       590           Et0/0      45.45.45.5 
//如上现象表明当前设备抵达6.6.6.0/24 本地标签403 远端 503,
//同时当前设备抵达3.3.3.0/24本地标签400 远端POP。

R5#show mpls forwarding-table                                                                                                                  
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop                                                                       
Label      Label      or Tunnel Id     Switched      interface                                                                                 
500        400        3.3.3.3/32       590           Et0/0      45.45.45.4                                                                     
501        No Label   4.4.4.4/32       0             Et0/0      45.45.45.4                                                                     
502        Pop Label  34.34.34.0/24    0             Et0/0      45.45.45.4                                                                     
503        No Label   6.6.6.6/32       570           Et0/1      56.56.56.6 
//如上现象表明当前设备抵达6.6.6.0/24 本地标签503 远端 POP,
//同时当前设备抵达3.3.3.0/24本地标签500 远端400。

R6#show mpls forwarding-table                                                                                                                  
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop                                                                       
Label      Label      or Tunnel Id     Switched      interface                                                                                 
600        500        3.3.3.3/32       0             Et0/1      56.56.56.5                                                                     
601        501        4.4.4.4/32       0             Et0/1      56.56.56.5                                                                     
602        No Label   5.5.5.5/32       0             Et0/1      56.56.56.5                                                                     
603        502        34.34.34.0/24    0             Et0/1      56.56.56.5                                                                     
604        Pop Label  45.45.45.0/24    0             Et0/1      56.56.56.5  
//如上现象表明当前设备抵达3.3.3.0/24本地标签600 远端 500,
//所以这个时候R3 R6可以利用LSP 帮助数据穿越P-NETWORK

完成R3 与 R6的BGP、MP-BGP,同时去校验。

R3(config)#router bgp 1                                                                                                                        
R3(config-router)#bgp router-id 1.1.1.1                                                                                                        
R3(config-router)#neighbor 6.6.6.6 remote-as 1                                                                                                 
R3(config-router)#neighbor 6.6.6.6 update-source loopback 0                                                                                    
R3(config-router)#address-family vpnv4                                                                                                         
R3(config-router-af)#neighbor 6.6.6.6 activate                                                                                                 
R3(config-router-af)#neighbor 6.6.6.6 send-community extended  

R6(config)#router bgp 1                                                                                                                        
R6(config-router)#bgp router-id 6.6.6.6                                                                                                        
R6(config-router)#neighbor 3.3.3.3 remote-as 1                                                                                                 
R6(config-router)#neighbor 3.3.3.3  update-source loopback 0                                                                                   
R6(config-router)#address-family vpnv4 unicast                                                                                                 
R6(config-router-af)#neighbor 3.3.3.3 activate  

此时我们在R3上校验MP-BGP PEER 关系是否建立;

R3#show ip  bgp  vpnv4 all summary                                                                                                             
BGP router identifier 1.1.1.1, local AS number 1                                                                                               
BGP table version is 1, main routing table version 1                                                                                           
                                                                                                                                               
Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd                                                        
6.6.6.6         4            1       5       5        1    0    0 00:00:49        0  

如上现象表明MP-BGP PEER 关系在R3 R6 间建立完毕。

完成PE设备上VRF的创建。

R3(config)#ip vrf   r18                                                                                                                        
R3(config-vrf)#rd 1:8                                                                                                                          
R3(config-vrf)#route-target 1:8                                                                                                                
R3(config)#ip vrf   r27                                                                                                                        
R3(config-vrf)#rd  2:7                                                                                                                         
R3(config-vrf)#route-target 2:7                                                                                                                
R3(config-vrf)#int e0/0.10                                                                                                                     
R3(config-subif)#ip vrf forwarding r18                                                                                                         
R3(config-subif)#ip  address 192.168.1.3  255.255.255.0                                                                                        
R3(config-subif)#int e0/0.20                                                                                                                   
R3(config-subif)#ip vrf forwarding r27                                                                                                         
R3(config-subif)#ip  address 192.168.2.3  255.255.255.0 

R6(config)#ip  vrf r18                                                                                                                         
R6(config-vrf)#rd 1:8                                                                                                                          
R6(config-vrf)#route-target 1:8                                                                                                                
R6(config)#ip  vrf r27                                                                                                                         
R6(config-vrf)#rd 2:7                                                                                                                          
R6(config-vrf)#route-target 2:7                                                                                                                
R6(config-subif)#ip  vrf forwarding r18                                                                                                        
R6(config-subif)#ip add 192.169.8.6 255.255.255.0                                                                                              
R6(config-subif)#int e0/0.70                                                                                                                   
R6(config-subif)#ip  vrf forwarding r27                                                                                                        
R6(config-subif)#ip add 192.169.7.6 255.255.255.0 

在PE 上用PING 做连通性测试时,请注意加VRF;

R3#ping vrf r18 192.168.1.1                                                                                                                    
Type escape sequence to abort.                                                                                                                 
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:                                                                           
!!!!!                                                                                                                                          
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms 

R3#ping vrf r27 192.168.2.2                                                                                                                    
Type escape sequence to abort.                                                                                                                 
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:                                                                           
!!!!!                                                                                                                                          
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms  
R6#ping vrf r18 192.168.8.8                                                                                                                    
Type escape sequence to abort.                                                                                                                 
Sending 5, 100-byte ICMP Echos to 192.168.8.8, timeout is 2 seconds:                                                                           
!!!!!                                                                                                                                          
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms 

R6#ping vrf r27 192.168.7.7                                                                                                                    
Type escape sequence to abort.                                                                                                                 
Sending 5, 100-byte ICMP Echos to 192.168.7.7, timeout is 2 seconds:                                                                           
!!!!!                                                                                                                                          
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms   

如上现象表明PE CE已经连通。

分别完成R3 R1、R3 R2 及R6 R7 、R6 R8上的PE和CE的路由信息共享。

R3(config)#ip route vrf r18 10.1.1.0 255.255.255.0 192.168.1.1                                                                                 
R3(config)#ip route vrf r18 11.11.11.0 255.255.255.0 192.168.1.1 
//利用静态路由命令给R3 VRF R18 注入抵达CE R1身后网络路由
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.3  
//利用静态路由命令给R1 注入下一跳为192.168.1.3的缺省
R2(config)#router rip                                                                                                                          
R2(config-router)#version 2                                                                                                                    
R2(config-router)#no auto-summary                                                                                                              
R2(config-router)#network 192.168.2.0                                                                                                          
R2(config-router)#network 10.0.0.0                                                                                                             
R2(config-router)#network 22.0.0.0 

R3(config)#router rip                                                                                                                          
R3(config-router)#version 2                                                                                                                    
R3(config-router)#no auto-summary                                                                                                              
R3(config-router)#address-family ipv4 vrf  r27                                                                                               
R3(config-router-af)#network 192.168.2.0 

此时校验R3 VRF R27 及VRF R18路由表确认收到CE 路由,并且可以通讯;

R3#show ip route vrf r18                                                                                                                       
                                                                                                                                               
                                                                                           
                                                                                                                                               
Gateway of last resort is not set                                                                                                              
                                                                                                                                               
      10.0.0.0/24 is subnetted, 1 subnets                                                                                                      
S        10.1.1.0 [1/0] via 192.168.1.1                                                                                                        
      11.0.0.0/24 is subnetted, 1 subnets                                                                                                      
S        11.11.11.0 [1/0] via 192.168.1.1                                                                                                      
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks                                                                                 
C        192.168.1.0/24 is directly connected, Ethernet0/0.10                                                                                  
L        192.168.1.3/32 is directly connected, Ethernet0/0.10  

R3#show ip route vrf r27                                                                                                                       
                                                                                                                                               
                                                                                                                                            
Gateway of last resort is not set                                                                                                              
                                                                                                                                               
      10.0.0.0/24 is subnetted, 1 subnets                                                                                                      
R        10.1.1.0 [120/1] via 192.168.2.2, 00:00:12, Ethernet0/0.20                                                                            
      22.0.0.0/24 is subnetted, 1 subnets                                                                                                      
R        22.22.22.0 [120/1] via 192.168.2.2, 00:00:06, Ethernet0/0.20                                                                          
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks                                                                                 
C        192.168.2.0/24 is directly connected, Ethernet0/0.20                                                                                  
L        192.168.2.3/32 is directly connected, Ethernet0/0.20  
R3#ping vrf r18 11.11.11.11                                                                                                                    
Type escape sequence to abort.                                                                                                                 
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:                                                                           
!!!!!                                                                                                                                          
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms  

R3#ping vrf  r27 22.22.22.22                                                                                                                   
Type escape sequence to abort.                                                                                                                 
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:                                                                           
!!!!!                                                                                                                                          
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
//如上现象表明R3 R1 R2 已经交换路由信息,放到不同的VRF表中,且可以通讯。
R6(config)#router eigrp 1                                                                                                                      
R6(config-router)#no auto-summary                                                                                                              
R6(config-router)#address-family ipv4  vrf r27  
R6(config-router-af)#autonomous-system 1                                                                                                
R6(config-router-af)#network 192.168.7.0 0.0.0.255 

R7(config)#router eigrp 1                                                                                                                      
R7(config-router)#no auto-summary                                                                                                              
R7(config-router)#network 10.0.0.0                                                                                                             
R7(config-router)#network 77.0.0.0                                                                                                             
R7(config-router)#network 192.168.7.0 

R6(config)#router  ospf  2  vrf r18                                                                                                            
R6(config-router)#router-id 66.66.66.66                                                                                                        
R6(config-router)#network 192.168.8.6 0.0.0.0 area 0 

R8(config)#router ospf 2                                                                                                                       
R8(config-router)#router-id 8.8.8.8                                                                                                            
R8(config-router)#network 10.2.2.0  0.0.0.255 area 0                                                                                           
R8(config-router)#network 88.88.88.0 0.0.0.255 area 0                                                                                          
R8(config-router)#network 192.168.8.0 0.0.0.255 area 0 

此时校验R6 上R18 及R27 路由表是否学习R7 R8路由,是否可以通讯;

R6#show ip route vrf r18                                                                                                                       
                                                                                                                                                                                                                                           
                                                                                                                                               
Gateway of last resort is not set                                                                                                              
                                                                                                                                               
      10.0.0.0/32 is subnetted, 1 subnets                                                                                                      
O        10.2.2.2 [110/11] via 192.168.8.8, 00:00:34, Ethernet0/0.80                                                                           
      88.0.0.0/32 is subnetted, 1 subnets                                                                                                      
O        88.88.88.88 [110/11] via 192.168.8.8, 00:00:34, Ethernet0/0.80                                                                        
      192.168.8.0/24 is variably subnetted, 2 subnets, 2 masks                                                                                 
C        192.168.8.0/24 is directly connected, Ethernet0/0.80                                                                                  
L        192.168.8.6/32 is directly connected, Ethernet0/0.80  

R6#show ip route vrf r27                                                                                                                       
                                                                                                                                                                                                                                          
                                                                                                                                               
Gateway of last resort is not set                                                                                                              
                                                                                                                                               
      10.0.0.0/24 is subnetted, 1 subnets                                                                                                      
D        10.2.2.0 [90/409600] via 192.168.7.7, 00:06:14, Ethernet0/0.70                                                                        
      77.0.0.0/24 is subnetted, 1 subnets                                                                                                      
D        77.77.77.0 [90/409600] via 192.168.7.7, 00:06:14, Ethernet0/0.70                                                                      
      192.168.7.0/24 is variably subnetted, 2 subnets, 2 masks                                                                                 
C        192.168.7.0/24 is directly connected, Ethernet0/0.70                                                                                  
L        192.168.7.6/32 is directly connected, Ethernet0/0.70  
R6#ping vrf r18 88.88.88.88                                                                                                                    
Type escape sequence to abort.                                                                                                                 
Sending 5, 100-byte ICMP Echos to 88.88.88.88, timeout is 2 seconds:                                                                           
!!!!!                                                                                                                                          
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms 

R6#ping vrf r27 77.77.77.77                                                                                                                    
Type escape sequence to abort.                                                                                                                 
Sending 5, 100-byte ICMP Echos to 77.77.77.77, timeout is 2 seconds:                                                                           
!!!!!                                                                                                                                          
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms 
//如上现象表明R6已经帮助VRF R18 和VRF R27 学习了对端路由。

PE 设备上完成IGPS 和MP-BGP 重分发:

R3(config)#router  bgp 1                                                                                                                       
R3(config-router)#address-family ipv4  vrf r18                                                                                                 
R3(config-router-af)#redistribute static                                                                                                       
R3(config-router-af)#address-family ipv4  vrf r27                                                                                              
R3(config-router-af)#redistribute rip                                                                                                          
R3(config-router-af)#router rip                                                                                                                
R3(config-router)#address-family ipv4  vrf r27                                                                                                 
R3(config-router-af)#redistribute bgp  1 metric 1 

R6(config)#router bgp 1                                                                                                                        
R6(config-router)#address-family ipv4  vrf r18                                                                                                 
R6(config-router-af)#redistribute ospf 2                                                                                                       
R6(config-router-af)#address-family ipv4  vrf r27                                                                                              
R6(config-router-af)#redistribute eigrp 1                                                                                                      
R6(config-router-af)#router eigrp  1                                                                                                           
R6(config-router)#address-family ipv4  vrf r27                                                                                                 
R6(config-router-af)#redistribute bgp  1 metric 10000 100 255 1 1500                                                                           
R6(config-router-af)#router ospf 2  vrf  r18                                                                                                   
R6(config-router)#redistribute bgp 1  subnets 

校验R3 R6 MP-BGP 转发表,确认重分发成功,且相互交换路由信息。

R3#show ip  bgp vpnv4 all                                                                                                                      
BGP table version is 18, local router ID is 1.1.1.1                                                                                            
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,                                                                
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,                                                                 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete                                                                                                 
RPKI validation codes: V valid, I invalid, N Not found                                                                                         
                                                                                                                                               
     Network          Next Hop            Metric LocPrf Weight Path                                                                            
Route Distinguisher: 1:8 (default for vrf r18)                                                                                                 
 *>  10.1.1.0/24      192.168.1.1              0         32768 ?                                                                               
 *>i 10.2.2.2/32      6.6.6.6                 11    100      0 ?                                                                               
 *>  11.11.11.0/24    192.168.1.1              0         32768 ?                                                                               
 *>i 88.88.88.88/32   6.6.6.6                 11    100      0 ?                                                                               
 *>i 192.168.8.0      6.6.6.6                  0    100      0 ?                                                                               
Route Distinguisher: 2:7 (default for vrf r27)                                                                                                 
 *>  10.1.1.0/24      192.168.2.2              1         32768 ?                                                                               
 *>i 10.2.2.0/24      6.6.6.6             409600    100      0 ?                                                                               
 *>  22.22.22.0/24    192.168.2.2              1         32768 ?                                                                               
 *>i 77.77.77.0/24    6.6.6.6             409600    100      0 ?                                                                               
 *>  192.168.2.0      0.0.0.0                  0         32768 ?  
R6#show ip bgp vpnv4 all                                                                                                                       
BGP table version is 17, local router ID is 6.6.6.6                                                                                            
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,                                                                
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,                                                                 
              x best-external, a additional-path, c RIB-compressed,                                                                            
Origin codes: i - IGP, e - EGP, ? - incomplete                                                                                                 
RPKI validation codes: V valid, I invalid, N Not found                                                                                         
                                                                                                                                               
     Network          Next Hop            Metric LocPrf Weight Path                                                                            
Route Distinguisher: 1:8 (default for vrf r18)                                                                                                 
 *>i 10.1.1.0/24      3.3.3.3                  0    100      0 ?                                                                               
 *>  10.2.2.2/32      192.168.8.8             11         32768 ?                                                                               
 *>i 11.11.11.0/24    3.3.3.3                  0    100      0 ?                                                                               
 *>  88.88.88.88/32   192.168.8.8             11         32768 ?                                                                               
 *>  192.168.8.0      0.0.0.0                  0         32768 ?                                                                               
Route Distinguisher: 2:7 (default for vrf r27)                                                                                                 
 *>i 10.1.1.0/24      3.3.3.3                  1    100      0 ?                                                                               
 *>  10.2.2.0/24      192.168.7.7         409600         32768 ?                                                                               
 *>i 22.22.22.0/24    3.3.3.3                  1    100      0 ?                                                                               
 *>  77.77.77.0/24    192.168.7.7         409600         32768 ?                                                                               
 *>i 192.168.2.0      3.3.3.3                  0    100      0 ?                                                                               
 *>  192.168.7.0      0.0.0.0                  0         32768 ? 

如上R3 R6的BGP转发表相互对照我们发现,他们已经相互交路由信息了。

在CE 设备上利用show ip route确认是否从PE得到对端路由。

R2#show ip route rip                                                                                                                           
                                                                                           
                                                                                                                                               
Gateway of last resort is not set                                                                                                              
                                                                                                                                               
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks                                                                                     
R        10.2.2.0/24 [120/1] via 192.168.2.3, 00:00:13, Ethernet0/0                                                                            
      77.0.0.0/24 is subnetted, 1 subnets                                                                                                      
R        77.77.77.0 [120/1] via 192.168.2.3, 00:00:13, Ethernet0/0                                                                             
R     192.168.7.0/24 [120/1] via 192.168.2.3, 00:00:13, Ethernet0/0 

R7#show ip route eigrp                                                                                                                         

                                                                                         
Gateway of last resort is not set                                                                                                              
                                                                                                                                               
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks                                                                                     
D EX     10.1.1.0/24 [170/307200] via 192.168.7.6, 00:03:01, Ethernet0/0                                                                       
      22.0.0.0/24 is subnetted, 1 subnets                                                                                                      
D EX     22.22.22.0 [170/307200] via 192.168.7.6, 00:03:01, Ethernet0/0                                                                        
D EX  192.168.2.0/24 [170/307200] via 192.168.7.6, 00:03:01, Ethernet0/0 

R8#show ip route ospf                                                                                                                          
                                                                                           
                                                                                                                                               
Gateway of last resort is not set                                                                                                              
                                                                                                                                               
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks                                                                                     
O E2     10.1.1.0/24 [110/1] via 192.168.8.6, 00:03:12, Ethernet0/0                                                                            
      11.0.0.0/24 is subnetted, 1 subnets                                                                                                      
O E2     11.11.11.0 [110/1] via 192.168.8.6, 00:03:12, Ethernet0/0 

//如上现象表明PE 设备成功的将MP-BGP 路由重分发进IGPS,并且PE 将其发送给了CE。

在PE 设备上查看栈底标签。

R3#show ip  bgp  vpnv4  all labels                                                                                                             
   Network          Next Hop      In label/Out label                                                                                           
Route Distinguisher: 1:8 (r18)                                                                                                                 
   10.1.1.0/24      192.168.1.1     305/nolabel                                                                                                
   10.2.2.2/32      6.6.6.6         nolabel/605                                                                                                
   11.11.11.0/24    192.168.1.1     306/nolabel                                                                                                
   88.88.88.88/32   6.6.6.6         nolabel/606                                                                                                
   192.168.8.0      6.6.6.6         nolabel/607                                                                                                
Route Distinguisher: 2:7 (r27)                                                                                                                 
   10.1.1.0/24      192.168.2.2     307/nolabel                                                                                                
   10.2.2.0/24      6.6.6.6         nolabel/608                                                                                                
   22.22.22.0/24    192.168.2.2     308/nolabel                                                                                                
   77.77.77.0/24    6.6.6.6         nolabel/609                                                                                                
   192.168.2.0      0.0.0.0         309/nolabel(r27)                                                                                           
   192.168.7.0      6.6.6.6         nolabel/610  

R6#show ip bgp vpnv4 all labels                                                                                                                
   Network          Next Hop      In label/Out label                                                                                           
Route Distinguisher: 1:8 (r18)                                                                                                                 
   10.1.1.0/24      3.3.3.3         nolabel/305                                                                                                
   10.2.2.2/32      192.168.8.8     605/nolabel                                                                                                
   11.11.11.0/24    3.3.3.3         nolabel/306                                                                                                
   88.88.88.88/32   192.168.8.8     606/nolabel                                                                                                
   192.168.8.0      0.0.0.0         607/nolabel(r18)                                                                                           
Route Distinguisher: 2:7 (r27)                                                                                                                 
   10.1.1.0/24      3.3.3.3         nolabel/307                                                                                                
   10.2.2.0/24      192.168.7.7     608/nolabel                                                                                                
   22.22.22.0/24    3.3.3.3         nolabel/308                                                                                                
   77.77.77.0/24    192.168.7.7     609/nolabel                                                                                                
   192.168.2.0      3.3.3.3         nolabel/309                                                                                                
   192.168.7.0      0.0.0.0         610/nolabel(r27) 

R3 上给11.11.11.0/24网络分配的栈底本地标签为306,该标签会成为MP-BGP 路由更新属性的一部分,共享给R6,所以在R6上看到的11.11.11.0/24远端的栈底标签信息为306。

R1 R8 互PING 测试MPLS VXN 是否提供有效的连通性。

R9#ping 6.6.6.6 source 192.168.9.9

Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
Packet sent with a source address of 192.168.9.9
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 92/125/164 ms

如上现象表明已经利用MPLS VXN 保障了C-NETWORK 的通信

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值