如有不对,不吝赐教
进入正题:
笛卡尔树是一种特殊的二叉树,其结点包含两个关键字K1和K2。首先笛卡尔树是关于K1的二叉搜索树,即结点左子树的所有K1值都比该结点的K1值小,右子树则大。其次所有结点的K2关键字满足优先队列(不妨设为最小堆)的顺序要求,即该结点的K2值比其子树中所有结点的K2值小。给定一棵二叉树,请判断该树是否笛卡尔树。
输入格式:
输入首先给出正整数N(≤1000),为树中结点的个数。随后N行,每行给出一个结点的信息,包括:结点的K1值、K2值、左孩子结点编号、右孩子结点编号。设结点从0~(N-1)顺序编号。若某结点不存在孩子结点,则该位置给出−1。
输出格式:
输出YES如果该树是一棵笛卡尔树;否则输出NO。
输入样例1:
6
8 27 5 1
9 40 -1 -1
10 20 0 3
12 21 -1 4
15 22 -1 -1
5 35 -1 -1
输出样例1:
YES
输入样例2:
6
8 27 5 1
9 40 -1 -1
10 20 0 3
12 11 -1 4
15 22 -1 -1
50 35 -1 -1
输出样例2:
NO
因为堆就是完全二叉树,所以可以直接用一棵二叉树来既当堆,又当搜索树。然后建树来判别是否符合条件就行了。因为各个节点是有自己的编号的,所以我使用静态链表来直接实现,就不用使用指针建树。
这里注意下第四个测试点,就是何为每棵子树都满足搜索树,但是整棵树不满足:
就是左子树中有节点比根节点大或者右子树中有节点比根小。
下面给出代码:
#include<stdio.h>
#include<stdbool.h>
struct DecareTree{
short K1,K2;
short left,right;
};
bool IsDecaTree(struct DecareTree *tree,short father);
bool IsBiTree(struct DecareTree *tree,short father);
int main(void)
{
short N,i;
short root;
bool is=true;
fscanf(stdin,"%hd",&N);
short father[N]; //用来寻找根节点
struct DecareTree tree[N]; //用静态链表结构来模拟树
for(i=0;i<N;i++)
father[i]=-1; //初始化父节点为自己
//那么最后父节点为-1的即为根节点
for(i=0;i<N;i++){
fscanf(stdin,"%hd %hd",&tree[i].K1,&tree[i].K2);
fscanf(stdin,"%hd %hd",&tree[i].left,&tree[i].right); //存储数据
father[tree[i].left]=i;
father[tree[i].right]=i; //记录父节点
}
for(i=0;i<N;i++)
if(-1==father[i]){
root=i;
break;
}
if(N){
is=IsDecaTree(tree,root);
is=is&&IsBiTree(tree,root);
}
if(is)
printf("YES");
else
printf("NO");
return 0;
}
bool IsDecaTree(struct DecareTree *tree,short father)
{
short left=tree[father].left;
short right=tree[father].right;
bool flag1,flag2;
if(-1!=left&&tree[father].K1<=tree[left].K1)
return false;
if(-1!=right&&tree[father].K1>=tree[right].K1)
return false; //不满足二叉树结构
if(-1!=left&&tree[father].K2>=tree[left].K2)
return false;
if(-1!=right&&tree[father].K2>=tree[right].K2)
return false; //不满足堆结构
if(-1!=left){
flag1=IsDecaTree(tree,left);
if(!flag1)
return false; //左子树不满足条件
}
if(-1!=right){
flag2=IsDecaTree(tree,right);
if(!flag2)
return false; //右子树不满足条件
}
return true; //到达结尾即满足所有条件
}
bool IsBiTree(struct DecareTree *tree,short father)
{
if(-1==tree[father].left&&-1==tree[father].right)
return true;
int cur; //表示当前访问的节点
cur=tree[father].left;
if(-1!=cur){
while(-1!=tree[cur].right)
cur=tree[cur].right; //找到左子树的最大值
if(tree[cur].K1>tree[father].K1)
return false;
}
cur=tree[father].right;
if(-1!=cur){
while(-1!=tree[cur].left)
cur=tree[cur].left;
if(tree[cur].K1<tree[father].K1)
return false;
}
if(!IsBiTree(tree,tree[father].left)&&!IsBiTree(tree,tree[father].right))
return false;
return true;
}
测试结果: