Muddy roads(区间覆盖)

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools.

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely.

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.

Input

* Line 1: Two space-separated integers: N and L

* Lines 2..N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap.

Output

* Line 1: The miminum number of planks FJ needs to use.

Sample Input

3 3
1 6
13 17
8 12

Sample Output

5

Hint

INPUT DETAILS:

FJ needs to use planks of length 3 to cover 3 mud pools. The mud pools cover regions 1 to 6, 8 to 12, and 13 to 17.

OUTPUT DETAILS:

FJ can cover the mud pools with five planks of length 3 in the following way:

                   111222..333444555....

                   .MMMMM..MMMM.MMMM....

                   012345678901234567890

这个题目是要把泥坑用木条覆盖,给定区间和木条长度,求至少需要多少木条

思路:先按坑出现的坐标排序(我是从小到大),然后处理第一个坑,求出需要多少木条可以覆盖(注意此处,我一开始用循环判定,令木条初值为1,然后++,直到大于等于坑的长度跳出,结果超时,其实只需坑长度除木条长度向上取整就可以了,唉,还是意识不够),剩余的看代码吧。

#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<cmath>
#include <algorithm>
#include <stdlib.h>
#include <cstdio>
#include<sstream>
#include<cctype>
#include <set>
#include<queue>
#include <map>
#include <iomanip>
typedef long long ll;
using namespace std;
struct node
{
  ll x,y;
};
node ans[100000];
bool cmp(node a,node b)
{
    return a.y<b.y;
}
int main()
{
    ll n,l,m;
    cin>>n>>l;
    for(ll i=0;i<n;i++)
    {
        cin>>ans[i].x>>ans[i].y;
    }
    sort(ans,ans+n,cmp);ll f=-1000;
   ll sum=0;
    for(ll i=0;i<n;i++)
    {
        if(f>=ans[i].y)  continue;
        if(f>ans[i].x)  ans[i].x=f;//如果上个木条尾坐标大于当前首坐标,令首坐标等于尾坐标,就是坐标区间的剪裁
        ll dis=ans[i].y-ans[i].x;
        double k=dis*1.0/l;
         k=ceil(k);

if(k*l-dis>0) ans[i].y=ans[i].y+k*l-dis;
        sum+=k;f=ans[i].y;

    }
    cout<<sum;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值