Pie(二分)

2651 - Pie

Problem Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

 

Input

One line with a positive integer: the number of test cases. Then for each test case:

  • One line with two integers N and F with 1 ≤ N, F ≤ 10,000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10,000: the radii of the pies.

 

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10-3.

 

Sample Input

 

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

 

Sample Output

 

25.1327
3.1416
50.2655

    题目大意是过生日分披萨,要分的同等面积大小的披萨,所有的披萨都是圆柱形,高度都相同,只是半径不同。f+1个人(要算上我)分n块披萨。求分的最大面积

   二分法。。注意合理寻找边界。

我去,忘了换行了,因为一个换行,太粗心了。。

AC code

#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<cmath>
#include <algorithm>
#include <stdlib.h>
#include <cstdio>
#include<sstream>
#include<cctype>
#include <set>
#include<queue>
#include <map>
//#include <windows.h>
#include <iomanip>
#define  INF  0x3f3f3f3f
#define exp   0.000001
#define mmt(a,b)  memset(a,b,sizeof(a))
typedef long long ll;
const ll MAX=1000000;
const double pi=3.14159265358979;
using namespace std;
int t,n,k;
double ans[10010];
bool judge(double num);
int main()
{

    cin>>t;double M_;
    while(t--)
    {
        cin>>n>>k;M_=-INF;
        for(int i=1;i<=n;++i)
        {
            double x;
            cin>>x;
            ans[i]=pi*x*x;
            M_=max(M_,ans[i]);

        }
        //H=sum;
        double L=0;
        double H=M_;
        double mid;
        while(fabs(H-L)>exp)
        {
            mid=L+(H-L)/2;
            if(judge(mid)) L=mid;
            else  H=mid;

        }
      printf("%.4lf\n",mid);//输出L也能AC,额,好像H也能AC,有点迷
    }
}
bool judge(double num)
{
    int sum=0;
    for(int i=1;i<=n;++i)
    {
        sum+=(int)(ans[i]/num);//这个int要加,不然过不了
    }
    if(sum>=k+1) return 1;
    else return 0;
}

waCODE

#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<cmath>
#include <algorithm>
#include <stdlib.h>
#include <cstdio>
#include<sstream>
#include<cctype>
#include <set>
#include<queue>
#include <map>
//#include <windows.h>
#include <iomanip>
#define  INF  0x3f3f3f3f
#define exp   0.000001
#define mmt(a,b)  memset(a,b,sizeof(a))
typedef long long ll;
const ll MAX=1000000;
const double pi=3.14159265358979;
using namespace std;
int t,n,k;
double ans[10010];
bool judge(double num);
int main()
{

    cin>>t;;
    while(t--)
    {
        cin>>n>>k;int sum=0;
        for(int i=1;i<=n;++i)
        {
            double x;
            cin>>x;
            ans[i]=pi*x*x;
            sum+=ans[i];


        }
        double L=0;
        double H=sum/(k+1);
        double mid;
        while(fabs(H-L)>exp)
        {
            mid=L+(H-L)/2;
            if(judge(mid)) L=mid;
            else  H=mid;

        }
      printf("%.4lf\n",mid);
    }
}
bool judge(double num)
{
    int sum=0;
    for(int i=1;i<=n;++i)
    {
        sum+=(int)(ans[i]/num);
    }
    if(sum>=k+1) return 1;
    else return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值