HDU-2577-How to Type(DP+枚举)

How to Type

Problem Description

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input

The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output

For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input

3
Pirates
HDUacm
HDUACM
 

Sample Output

8
8
8

Hint

The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

解题思路:

开dp[N][2]的二维数组来记录大写键的开闭情况,dp[i][0]表示输入第i个字母后大写灯是灭的,dp[i][1]表示大写灯是开着的,那么关于状态转移,需要枚举4种情况,即当前字母是大写还是小写,上一次是大写状态还是小写状态,每一种情况需要的步数不一样,如果是相同的状态,只要+1就行,否则需要加2。

AC代码:

#include <bits/stdc++.h>
#define int long long

using namespace std;
const int N = 1e6+10;
const int mod = 1e9+7;
int a[N];
int dp[105][2];
signed main()
{
    int n,m,k;
    int t = 1;
    cin>>t;
    int cas = 1;
    int cnt = 0;
    while(t--)
    {
        string s;
        cin>>s;
        n = s.size();
        for(int i = 0 ; i < n ; i ++)
        {
            if(s[i] >= 'a' && s[i] <= 'z')
                a[i] = 0;
            else
                a[i] = 1;
        }
        dp[0][0] = a[0] == 0 ? 1 : 2;
        dp[0][1] = 2;
        for(int i = 1 ; i < n ; i ++)
        {
            if(a[i] == 0) // 当前是小写字母
            {
                dp[i][0] = min(dp[i-1][0] + 1 , dp[i-1][1] + 2);
                dp[i][1] = min(dp[i-1][1] + 2 , dp[i-1][0] + 2);
            }
            else // 当前是大写字母
            {
                dp[i][0] = min(dp[i-1][0] + 2 , dp[i-1][1] + 2);
                dp[i][1] = min(dp[i-1][1] + 1 , dp[i-1][0] + 2);
            }
        }
        dp[n-1][1] ++;
        cout<<min(dp[n-1][0],dp[n-1][1])<<endl;
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值